summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-01-08 01:27:25 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-01-24 19:30:54 +0200
commit043e0a28bd1bc3e00a21644b725f18ac853b0226 (patch)
tree53e4389464cde2a1274518a6b4e8dfe6f3ea170e /gnome-extra
parentx11-wm/muffin: 4.8.1 version bump (diff)
downloadgentoo-043e0a28bd1bc3e00a21644b725f18ac853b0226.tar.gz
gentoo-043e0a28bd1bc3e00a21644b725f18ac853b0226.tar.bz2
gentoo-043e0a28bd1bc3e00a21644b725f18ac853b0226.zip
gnome-extra/nemo: 4.8.4 version bump
Bug: https://bugs.gentoo.org/757708 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nemo/Manifest1
-rw-r--r--gnome-extra/nemo/files/nemo-4.6-captions-fix.patch28
-rw-r--r--gnome-extra/nemo/nemo-4.8.4.ebuild101
3 files changed, 130 insertions, 0 deletions
diff --git a/gnome-extra/nemo/Manifest b/gnome-extra/nemo/Manifest
index 5b96c54a5692..014d5d61fcad 100644
--- a/gnome-extra/nemo/Manifest
+++ b/gnome-extra/nemo/Manifest
@@ -1 +1,2 @@
DIST nemo-4.6.5.tar.gz 1468701 BLAKE2B 42b47300782745e4ae98db164ca547b0794caf8f0883db4241f2f0ed2e375e5c8564cff6d878142b55744ce41f49c60aad3f24930398ff68444e32c572d7e9bd SHA512 3c8c95e75e8bc499b56d1fd133f5ccc86ad18dae2219772b732586fd684a4a7a36e51fa61e6b734ad182ffd96636bdf276b8645d049e5ca68795fac274236eb6
+DIST nemo-4.8.4.tar.gz 1464683 BLAKE2B 10945a385defdf1bdc7fac9432306e31476ec015489a5150a5b4f9d5f31977b93da6e92241ce153cd5435c789c7a6ce16d2a86002758f26fc587a33dc5343e63 SHA512 b63ee2bd85f67e7d18271032ac3d95c7446b5110b71a3236f7e8c4ccb31e2baf11912060dde36f12ed4b90491c3bb1215a0de38c419130d692c775031cc0e11e
diff --git a/gnome-extra/nemo/files/nemo-4.6-captions-fix.patch b/gnome-extra/nemo/files/nemo-4.6-captions-fix.patch
new file mode 100644
index 000000000000..0ea0c9158ad2
--- /dev/null
+++ b/gnome-extra/nemo/files/nemo-4.6-captions-fix.patch
@@ -0,0 +1,28 @@
+From b0c2b99b46797ca91bdba1d95fda33808174466b Mon Sep 17 00:00:00 2001
+From: Michael Webster <miketwebster@gmail.com>
+Date: Thu, 21 Jan 2021 09:41:40 -0500
+Subject: [PATCH] nemo-icon-canvas-item.c: restore the style context after
+ drawing any caption text.
+
+This seemed to be causing style recalculations to accumulate over
+time, and particularly when changing the style for window focus
+in/out events. This would eventually have a huge impact on user
+interaction.
+
+Fixes #2472
+---
+ libnemo-private/nemo-icon-canvas-item.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libnemo-private/nemo-icon-canvas-item.c b/libnemo-private/nemo-icon-canvas-item.c
+index d1b6cbfad..b32de357d 100644
+--- a/libnemo-private/nemo-icon-canvas-item.c
++++ b/libnemo-private/nemo-icon-canvas-item.c
+@@ -1143,6 +1143,7 @@ draw_label_text (NemoIconCanvasItem *item,
+ gtk_render_layout (context, cr,
+ x, text_rect.y0 + details->editable_text_height + LABEL_LINE_SPACING + TEXT_TOP_GAP,
+ additional_layout);
++ gtk_style_context_restore (context);
+ }
+
+ if (item->details->is_highlighted_as_keyboard_focus) {
diff --git a/gnome-extra/nemo/nemo-4.8.4.ebuild b/gnome-extra/nemo/nemo-4.8.4.ebuild
new file mode 100644
index 000000000000..d306690d78f6
--- /dev/null
+++ b/gnome-extra/nemo/nemo-4.8.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit meson gnome2-utils python-single-r1 virtualx xdg
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/nemo"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc exif +nls selinux test tracker xmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# https://github.com/linuxmint/nemo/issues/2501
+RESTRICT="test"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.45.7:2[dbus]
+ >=dev-libs/gobject-introspection-0.9.12:=
+ >=dev-libs/libxml2-2.7.8:2
+ gnome-base/dconf:0=
+ >=gnome-extra/cinnamon-desktop-4.8:0=
+ >=x11-libs/gtk+-3.10.0:3[introspection]
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ >=x11-libs/pango-1.40.0
+ >=x11-libs/xapps-2.0.5
+
+ exif? ( >=media-libs/libexif-0.6.20:= )
+ selinux? ( sys-libs/libselinux )
+ tracker? ( >=app-misc/tracker-2.0:= )
+ xmp? ( >=media-libs/exempi-2.2.0:= )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-themes/adwaita-icon-theme
+
+ nls? ( >=gnome-extra/cinnamon-translations-4.8 )
+"
+PDEPEND="
+ >=gnome-base/gvfs-0.1.2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.31.0
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ # Fix performance regression when icon captions enabled.
+ # https://github.com/linuxmint/nemo/issues/2472
+ "${FILESDIR}/${PN}-4.6-captions-fix.patch"
+)
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ python_fix_shebang files/usr/share/nemo/actions
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif)
+ $(meson_use tracker)
+ $(meson_use xmp)
+ $(meson_use selinux)
+ $(meson_use doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}