summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-14 12:47:22 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-14 12:47:22 +0200
commit10a7dd2b8bfcb0172b0278b44e4f2c960d2da101 (patch)
tree8b1db22bbd6668947c2995964c31527e7db0f941 /gnome-extra
parentapp-crypt/seahorse: build depend on libsecret[vala] (diff)
downloadgentoo-10a7dd2b8bfcb0172b0278b44e4f2c960d2da101.tar.gz
gentoo-10a7dd2b8bfcb0172b0278b44e4f2c960d2da101.tar.bz2
gentoo-10a7dd2b8bfcb0172b0278b44e4f2c960d2da101.zip
gnome-extra/gnome-system-monitor: bump to 3.30.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.30.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index 764692d2aae9..3549c3490218 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1,3 +1,4 @@
DIST gnome-system-monitor-3.24.0.tar.xz 930956 BLAKE2B f08b6da2ee9d45d232f1d1f019b6844f6fcf50baf85944d240611fbc0794cce6755d6b7daf275f4d97686558fc0f2525a8700fda473b576f8d5d41f66f118275 SHA512 4155d9f130cc1e38d32b76d10ca91056d82b90ca555f9ded26acfd1ef018b92163b0cc2256861b8e166b3bfa7eadc6c900aa9c79fd0c859045197ab2eaf3dc9f
DIST gnome-system-monitor-3.26.0.tar.xz 941144 BLAKE2B bde11ed78b10140916121df49af36b04afc6d9cb35fc1fa4f240ab8c109b79bfce5175d0e91e7a80c6da5420e13ca2aa520e76db9b79ea08d5dab23fcd8a301a SHA512 c2593371d956a4c11ad9ac4afabc996c02d743f9ba443192b0d955ab42464a02ad3fe19398b9489d33d552fdfdc2fb615e85d4dcb9342b821cb0b590fd3c3043
DIST gnome-system-monitor-3.28.2.tar.xz 1209156 BLAKE2B 6b23617ce1168eb1144affee0a7234fb7a86cc94cdf8220ce56c685604392db24359b4870238a7e96cd6a6e72b3130d77dd34c7cfa240c4c650b936d7ba42335 SHA512 8c55e97174c7334b19b8d9ef171d3dc97bdb2de4fb8442471e55ae6a0bbf0608e78eee3aafefda8a4a0375b804e5332dce692f3bd6676b4b623aa5be4c87b948
+DIST gnome-system-monitor-3.30.0.tar.xz 762004 BLAKE2B cf0ef6dde12a34f537e632dca6b45fc16ab49e92aaf49d2e945dded25b5cfbd855506368b82a0f840808760ce563f54fd8683f5a35652a5e10cdb4972ea61864 SHA512 c33dc510b15019de745a88d3eef12b5a2b19048bda22878988f22c4482f6a26ab20f5913f3104f2cb1b9566f7148a08b53d4e548f71345363273c51840fa2c8a
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.30.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.30.0.ebuild
new file mode 100644
index 000000000000..befb87d28d10
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.30.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}