summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-01-08 02:02:30 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-01-24 19:30:55 +0200
commit2c2bec3cdc2f8431a532d9ba37c310600aa98be7 (patch)
tree7a2d80c3d209e4adabb1b6a95d66304975cb4e85 /gnome-extra
parentgnome-extra/cinnamon-session: 4.8.0 version bump (diff)
downloadgentoo-2c2bec3cdc2f8431a532d9ba37c310600aa98be7.tar.gz
gentoo-2c2bec3cdc2f8431a532d9ba37c310600aa98be7.tar.bz2
gentoo-2c2bec3cdc2f8431a532d9ba37c310600aa98be7.zip
gnome-extra/cinnamon: 4.8.6 version bump
Project was converted to meson. Closes: https://bugs.gentoo.org/757708 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon/Manifest1
-rw-r--r--gnome-extra/cinnamon/cinnamon-4.8.6.ebuild176
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch28
-rw-r--r--gnome-extra/cinnamon/files/polkit-cinnamon-authentication-agent-1.desktop1
4 files changed, 206 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/Manifest b/gnome-extra/cinnamon/Manifest
index 8bcf7676aeb1..4b8090b8a3d7 100644
--- a/gnome-extra/cinnamon/Manifest
+++ b/gnome-extra/cinnamon/Manifest
@@ -1 +1,2 @@
DIST cinnamon-4.6.7.tar.gz 2271281 BLAKE2B bbf8a5d82b6bd27a8578aebb30ed0df4190ef2addfc0d820448e70d4db6b3d8df633a5f33178b29fd2c012045e1790df60a4b1b281fdd70eda53caa5cacc0d7b SHA512 4807d5330c1e2a7e1804257b88dbec2822aa386b0bc2fe2d3aca8e5a27125703987dbabca35360e99216e7b4370bcf6339de562026b48529442a4edda6eb9070
+DIST cinnamon-4.8.6.tar.gz 2378117 BLAKE2B ae98bf81aa3b2f26d33aa1b5a8109b50d969cb3568322159808c23d13fea6a11790d877a446b3ee4a54f5811fddfb5fca220f46bc213ffc2aa4560e344563f9d SHA512 827d93fa72213e00977d6318da25d9b03279666485ed4c4fd45ece9914c7481f39fa98c64940529a7459cc239783caa9427a2a702f77ffb77fb2c38073e42bbd
diff --git a/gnome-extra/cinnamon/cinnamon-4.8.6.ebuild b/gnome-extra/cinnamon/cinnamon-4.8.6.ebuild
new file mode 100644
index 000000000000..bba04d8152f6
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-4.8.6.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="xml"
+
+inherit meson gnome2-utils pax-utils python-single-r1 xdg
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon"
+SRC_URI="https://github.com/linuxmint/cinnamon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+gstreamer gtk-doc +nls +networkmanager"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ app-accessibility/at-spi2-atk:2
+ >=dev-libs/glib-2.52.0:2[dbus]
+ >=dev-libs/gobject-introspection-1.29.15:=
+ dev-libs/libxml2:2
+ >=gnome-extra/cinnamon-desktop-4.8:0=
+ >=gnome-extra/cinnamon-menus-4.8
+ >=gnome-extra/cjs-4.8[cairo]
+ net-libs/libsoup:2.4[introspection]
+ sys-apps/dbus
+ >=sys-auth/polkit-0.100[introspection]
+ virtual/opengl
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12.0:3[introspection]
+ >=x11-libs/libnotify-0.7.3:0=[introspection]
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ x11-libs/pango[introspection]
+ >=x11-libs/startup-notification-0.11
+ >=x11-wm/muffin-4.8.0[introspection]
+
+ gstreamer? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ )
+ networkmanager? (
+ net-misc/networkmanager[introspection]
+ )
+"
+# caribou used by onscreen keyboard
+# libtimezonemap used by datetime settings
+# iso-flag-png (unpackaged) used by keyboard layout settings
+RDEPEND="
+ ${DEPEND}
+ >=app-accessibility/caribou-0.3
+ dev-libs/keybinder:3[introspection]
+ dev-libs/libtimezonemap
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/pypam[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ dev-python/xapp[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ >=gnome-base/libgnomekbd-2.91.4
+ >=gnome-extra/cinnamon-control-center-4.8[networkmanager=]
+ >=gnome-extra/cinnamon-screensaver-4.8
+ >=gnome-extra/cinnamon-session-4.8
+ >=gnome-extra/cinnamon-settings-daemon-4.8
+ >=gnome-extra/nemo-4.8
+ gnome-extra/polkit-gnome
+ net-misc/wget
+ sys-apps/accountsservice[introspection]
+ sys-power/upower[introspection]
+ >=x11-libs/xapps-2.0.5[introspection]
+ x11-misc/xdg-utils
+ x11-themes/adwaita-icon-theme
+ x11-themes/gnome-themes-standard
+
+ nls? (
+ >=gnome-extra/cinnamon-translations-4.8
+ )
+"
+BDEPEND="
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ # Fix backgrounds path as cinnamon doesn't provide them
+ # https://github.com/linuxmint/Cinnamon/issues/3575
+ "${FILESDIR}"/${PN}-3.8.0-gnome-background-compatibility.patch
+
+ # Use wheel group instead of sudo (from Fedora/Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3576
+ "${FILESDIR}"/${PN}-3.6.6-wheel-sudo.patch
+
+ # GStreamer only needed for recorder
+ # https://github.com/linuxmint/cinnamon/pull/9809
+ "${FILESDIR}"/${PN}-4.8.6-build-fixes.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ # Add polkit agent to required components
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ sed -i "s/'REQUIRED', '/&polkit-cinnamon-authentication-agent-1;/" meson.build || die
+
+ # shebang fixing craziness
+ local p
+ for p in $(grep -rl '#!.*python3' || die); do
+ python_fix_shebang "${p}"
+ done
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gstreamer build_recorder)
+ $(meson_use gtk-doc docs)
+ -Ddisable_networkmanager=$(usex networkmanager false true)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ python_optimize "${ED}"/usr/share/cinnamon/
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}"/usr/bin/cinnamon
+
+ # Doesn't exist on Gentoo, causing this to be a dead symlink
+ rm "${ED}/etc/xdg/menus/cinnamon-applications-merged" || die
+
+ # Ensure authentication-agent is started, bug #523958
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ insinto /etc/xdg/autostart/
+ doins "${FILESDIR}"/polkit-cinnamon-authentication-agent-1.desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if use gstreamer; then
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "org.cinnamon.recorder/pipeline to what you want to use."
+ fi
+ else
+ ewarn "Cinnamon's built-in screen recording utility is disabled."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch b/gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch
new file mode 100644
index 000000000000..bc4476a5892e
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch
@@ -0,0 +1,28 @@
+diff --git a/meson.build b/meson.build
+index a4d49a16..eff937ac 100644
+--- a/meson.build
++++ b/meson.build
+@@ -36,8 +36,6 @@ gio_unix = dependency('gio-unix-2.0')
+ gl = dependency('gl')
+ glib_version = '2.52.0'
+ glib = dependency('glib-2.0', version: '>= ' + glib_version)
+-gstreamer = dependency('gstreamer-1.0')
+-gstreamer_base = dependency('gstreamer-base-1.0')
+ gtk = dependency('gtk+-3.0', version: '>= 3.12.0')
+ muffin = dependency('libmuffin', version: '>= 4.0.3')
+ muffinlibdir = muffin.get_pkgconfig_variable('typelibdir')
+@@ -53,6 +51,14 @@ if has_nm
+ dependency('libnm')
+ endif
+
++if get_option('build_recorder')
++ gstreamer = dependency('gstreamer-1.0')
++ gstreamer_base = dependency('gstreamer-base-1.0')
++else
++ gstreamer = dependency('', required: false)
++ gstreamer_base = dependency('', required: false)
++endif
++
+ # on some systems we need to find the math lib to make sure it builds
+ cc = meson.get_compiler('c')
+ math = cc.find_library('m', required: false)
diff --git a/gnome-extra/cinnamon/files/polkit-cinnamon-authentication-agent-1.desktop b/gnome-extra/cinnamon/files/polkit-cinnamon-authentication-agent-1.desktop
index 24e14f267e23..c0cccca89d58 100644
--- a/gnome-extra/cinnamon/files/polkit-cinnamon-authentication-agent-1.desktop
+++ b/gnome-extra/cinnamon/files/polkit-cinnamon-authentication-agent-1.desktop
@@ -1,5 +1,6 @@
[Desktop Entry]
Name=PolicyKit Authentication Agent
+Comment=PolicyKit Authentication Agent
Exec=/usr/libexec/polkit-gnome-authentication-agent-1
Terminal=false
Type=Application