summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 14:12:05 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:12:05 +0100
commit65d9423368a65d2d82bc58dffcb5c037850b5dd1 (patch)
treed709582a2cfed3bdbf07cb332b618f542a083351 /gnome-extra
parentgames-misc/sound-of-sorting: add 0.6.6_pre20221012 (diff)
downloadgentoo-65d9423368a65d2d82bc58dffcb5c037850b5dd1.tar.gz
gentoo-65d9423368a65d2d82bc58dffcb5c037850b5dd1.tar.bz2
gentoo-65d9423368a65d2d82bc58dffcb5c037850b5dd1.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: add 36.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-36.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
index 6302a916cb12..a3272926f38c 100644
--- a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-alphabetical-grid-32.0.tar.gz 214580 BLAKE2B b3fd0be85c5f74240f25a96b041df6ca0e3cf02b2b025eb2ffa5f1e3ed9f9562dac3ee37b7a32a548b3a8054ad8728a9d93c9bd84d771eadb0c9d56b2366cd97 SHA512 8ac96bea822df28cd980179a19d3f7acb8a950b3f1e41e650ff2982cb3b657434a0eb49357ebd206b68de102bb3c89b823f16cbcd379e7807598b923e5a64c6c
DIST gnome-shell-extension-alphabetical-grid-35.0.tar.gz 215465 BLAKE2B 981bd47a47ab4c0b4d521a6d48164ae2edd2d883f38e37d3bda5f60eb75f0e3e27d607130e35d5a280593de2ab7955f29d8c0d76ca7bd5de33281a4d175a5d72 SHA512 af3641284361587adc6a8a8beefb95da8e35fbe2a505e7e21fd14afebb76175500745c4fe0b1bdbf0482a6c74c5facd6786aa59ec7f8cc2498b64f33aad255e7
+DIST gnome-shell-extension-alphabetical-grid-36.0.tar.gz 215631 BLAKE2B 339fc9d6fde299b2c989aa135d1eb7f6d95d5c3cedf1e38ed17b1a280cac4092aea361fe44fa957b7ec3a821f7f51514d10dda4ad195734fb92f0278453a02ee SHA512 4c7b5e32b14e59e2d80e84a0d039b0655750e2f1eb75e20a4c903a6a24b813c0378644db449e757e35c6eb27b69598bd614294a3e631853bb3c628b3eac322af
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-36.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-36.0.ebuild
new file mode 100644
index 000000000000..3c2e00a566a1
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-36.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+ gui-libs/libadwaita
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Tests are only useful for upstream
+RESTRICT="test"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ mv docs/icon.svg extension || die
+ cd extension || die
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}