summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-14 18:22:03 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-14 18:57:32 +0200
commit73a7098efd259c2768bc57256b0ab5dfc7da56f9 (patch)
tree41a915cf60b361c2ff2c487bc3003d7ed34a5171 /gnome-extra
parentprofiles/package.mask: add evolution-ews to Gnome 3.24 mask (diff)
downloadgentoo-73a7098efd259c2768bc57256b0ab5dfc7da56f9.tar.gz
gentoo-73a7098efd259c2768bc57256b0ab5dfc7da56f9.tar.bz2
gentoo-73a7098efd259c2768bc57256b0ab5dfc7da56f9.zip
gnome-extra/evolution-ews: version bump 3.22.6 → 3.24.5
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.24.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index fbb55c7799bf..3eda37c95010 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.22.6.tar.xz 715320 SHA256 eddc94d9a7f759a20dc35a8635318a425f8687bb3af5b72b94c996101c8fb0e5 SHA512 6b93faa67a6f546142b023086bf54ac34d6c7c4320ee136f58cc0ea5a018811af2080d5945c4dc68c89555a35a4194b2f92bd839b2142ae63690e94ed895b40e WHIRLPOOL b242c15acbeefc7f6010d106a7e6b9d5dd3d3bab94069cca95a2d722403dbe284ed633b818120f3a47d2d9056e2cfa160ac0984f71c24fc271debbe93aeb319d
+DIST evolution-ews-3.24.5.tar.xz 488116 SHA256 db77200f139b2e37ad7d881eedeb5a9e9c84ae5a6194fde8d4d80099559943d1 SHA512 eaa5096c09686dade6f1efddea2b706a73c292b06b473b0f2ef1ba15eb5a3d685678416a0f1de40296beaa893d5dc91b944a440440dba489df67a944342f2f17 WHIRLPOOL 1a43e9f12b596a76974a3c1755a6ee6a6e760039d636d32ec2de166e082d8fdabaae4f37919507d54ef7a9ee86c98a3876755e7a36bc446fd1fc619698642505
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.24.5.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.24.5.ebuild
new file mode 100644
index 000000000000..87e553e77c4e
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.24.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.46:2
+ dev-libs/libical:0=
+ >=dev-libs/libmspack-0.4
+ >=dev-libs/libxml2-2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}