summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-19 16:47:30 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-19 17:13:48 +0200
commitc2c6a9e859fdbd02252e6dc6ab2e15b45dab165f (patch)
tree111d5846fb12ac18064fd7a70033905ebce55e1f /gnome-extra
parentmedia-gfx/simple-scan: bump to 3.36.7 (diff)
downloadgentoo-c2c6a9e859fdbd02252e6dc6ab2e15b45dab165f.tar.gz
gentoo-c2c6a9e859fdbd02252e6dc6ab2e15b45dab165f.tar.bz2
gentoo-c2c6a9e859fdbd02252e6dc6ab2e15b45dab165f.zip
gnome-extra/yelp: bump to 3.36.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/yelp-3.36.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index 96241ec92d49..a2087a714cd7 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1 +1,2 @@
DIST yelp-3.36.0.tar.xz 1538076 BLAKE2B d3f8817a54506997581ddc5477c87e2b61be0303c275e9174602a005838f141b1b7ad1904b682dfe3cf1118aaf497abbbfc855c5b57e2f7f3fdf6108a90f3ef1 SHA512 533916c61f6c0c830ddd21533c4462bea8493c76246092b1d77fa145f29cda15ae01817a4ac680bdf61ed591513320faf48e0aa727567c677fdb0ad66b6fa0c8
+DIST yelp-3.36.2.tar.xz 1526300 BLAKE2B f33bbbab9c02d36d8d2472735b661f5a29bfae8b104851e202a0b825390c308500fe108b6a7741ddf0774b2657f772bf94b69051b089b98009ab49a1cc55e4f5 SHA512 eabf1513a723c208d63c728aa08da641672b93f026317258f5732371e9837ab7626d2dcaf609da7982458fe2caf76a6d7607042d073bb5779a2e3916e938af0d
diff --git a/gnome-extra/yelp/yelp-3.36.2.ebuild b/gnome-extra/yelp/yelp-3.36.2.ebuild
new file mode 100644
index 000000000000..4c46c28a79fe
--- /dev/null
+++ b/gnome-extra/yelp/yelp-3.36.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-3.27.1
+ >=net-libs/webkit-gtk-2.19.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.13
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch # needs eautoreconf
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-bz2 \
+ --enable-lzma \
+ APPSTREAM_UTIL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}