summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-19 13:54:39 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-19 13:54:39 +0200
commitd70e945c407fa69d840c50a2e43b3eeca23fca6a (patch)
tree582510e6ba429a96b3292588a17d4e340c0ea38a /gnome-extra
parentgnome-extra/gnome-contacts: fix build with USE=telepathy (diff)
downloadgentoo-d70e945c407fa69d840c50a2e43b3eeca23fca6a.tar.gz
gentoo-d70e945c407fa69d840c50a2e43b3eeca23fca6a.tar.bz2
gentoo-d70e945c407fa69d840c50a2e43b3eeca23fca6a.zip
gnome-extra/gnome-contacts: bump to 3.38.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-contacts/Manifest1
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.38.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gnome-extra/gnome-contacts/Manifest b/gnome-extra/gnome-contacts/Manifest
index 0603b79364c3..e3737753cef7 100644
--- a/gnome-extra/gnome-contacts/Manifest
+++ b/gnome-extra/gnome-contacts/Manifest
@@ -1 +1,2 @@
DIST gnome-contacts-3.36.2.tar.xz 635932 BLAKE2B 9bcdf093d99477d1162c9ea78007e65cf20a1e4038fe284fafa4c174ab1d1d0c2ceb7ec2806c9abeed1c8ab168549c80b2763e65ece22c76a9044781eef8ed5d SHA512 ebbce67aa5c0af55559230c558c5f28b065182d434582431595bffedc25dd0ec3caa44e60f4670b4b2a1f784e90c8dd4f56df937054697b4ea932a39da78f1c1
+DIST gnome-contacts-3.38.1.tar.xz 657376 BLAKE2B 5c042566ad99be1bda454466dcc2a42d6494cfbfb5a9f60eb0fa718a8d9bcbb986798ec48a87d5d322989b22d0fac2eee69df852ae39ba8a228ad91f50247c30 SHA512 bc2ed06d491c4773b9cedb2c51dc390a95d0271cf22d54864f5da4d892f80efece3cbdc1b90b4497f730039c8c83065b2a0ca590cecec579f011dd324ff8f134
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.38.1.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.38.1.ebuild
new file mode 100644
index 000000000000..279d1ad7f841
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.38.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="telepathy v4l"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.54
+ dev-libs/folks[vala(+)]
+ net-libs/gnome-online-accounts[vala]
+ gnome-extra/evolution-data-server[gtk,vala]
+ telepathy? ( net-libs/telepathy-glib[vala] )
+ >=gui-libs/libhandy-1.0.0:1[vala]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=gnome-extra/evolution-data-server-3.30:=[gnome-online-accounts]
+ >=dev-libs/folks-0.11.4:=[eds,telepathy?]
+ >=dev-libs/glib-2.58:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-base/gnome-desktop-3.0:3=
+ net-libs/gnome-online-accounts:=
+ >=x11-libs/gtk+-3.23.1:3
+ v4l? ( >=media-video/cheese-3.5.91:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.22 )
+ >=gui-libs/libhandy-0.0.12:0.0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${VALA_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature v4l cheese)
+ $(meson_use telepathy)
+ -Dmanpage=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}