summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-07 15:52:47 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:13 +0200
commitdb7998f698dd5555e28a39ec944fe9e563c0aab4 (patch)
tree4c8508a3f8d065c38c3860b478be56292548ed1e /gnome-extra
parentgnome-extra/gnome-tweaks: Version bump to 45.0 (diff)
downloadgentoo-db7998f698dd5555e28a39ec944fe9e563c0aab4.tar.gz
gentoo-db7998f698dd5555e28a39ec944fe9e563c0aab4.tar.bz2
gentoo-db7998f698dd5555e28a39ec944fe9e563c0aab4.zip
gnome-extra/zenity: Version bump to 3.99.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32676 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/files/3.99.2-Make-help2man-depend-on-manpage-option.patch28
-rw-r--r--gnome-extra/zenity/zenity-3.99.2.ebuild54
3 files changed, 83 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 4edef81b711c..3b54b5f83663 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,2 +1,3 @@
DIST zenity-3.44.2.tar.xz 3095752 BLAKE2B 07d5b9aa673ae1e719bbd8d2ff85394ce19b9e77c36c3b6cf73d6b806dbcb0ab6322d13e66a715ebf5aefc14fa289a31367d0f0abd6ceaa9df7e3d7d12049492 SHA512 60f139b18db9ddf95a9c3481b08a3b99dd56ce457a49d99dc33f59570837e8498e8819bdd130c915a08e40042b2f3af583bd0fe4498adb8152632bd044137f2f
DIST zenity-3.99.1.tar.xz 3086092 BLAKE2B cf43be455f97e1ecf0539339d515415c9f875a5a0ac961f11b6e2fe463362eae400633628132ed67c67c01dd61a39cba2dc247ad3b82449d51867a9d93bda2c1 SHA512 4be34682da266b79e05e56a862e698bd93bb2187b4395b699be8ba63053dac07a0f9598bba411fb1f06dc2fffab78829a791f797e66665ada23d1eac3463b3a8
+DIST zenity-3.99.2.tar.xz 3084880 BLAKE2B a6ae2a465516f2e019ad5bec5a4f5bad42dc499f85e5f293804d18c572a3f2dd69224ceb6dfc62156aaff587d8a4e78549e8cc88493c842a6ad056ce58c85920 SHA512 6130c01e34e74bd6d068cbd6d3c1e208fce73cbce61851482e0dbc5c24322953899b6de7859ed86fe89850a1650ad28f8815cf709c152c02a685725350260afb
diff --git a/gnome-extra/zenity/files/3.99.2-Make-help2man-depend-on-manpage-option.patch b/gnome-extra/zenity/files/3.99.2-Make-help2man-depend-on-manpage-option.patch
new file mode 100644
index 000000000000..8c9de5f67290
--- /dev/null
+++ b/gnome-extra/zenity/files/3.99.2-Make-help2man-depend-on-manpage-option.patch
@@ -0,0 +1,28 @@
+https://gitlab.gnome.org/GNOME/zenity/-/commit/8a76b35828b7354f042684afa65ea696c7349af7
+https://gitlab.gnome.org/GNOME/zenity/-/merge_requests/33
+
+From 8a76b35828b7354f042684afa65ea696c7349af7 Mon Sep 17 00:00:00 2001
+From: Guillermo Joandet <gjoandet@gmail.com>
+Date: Wed, 13 Sep 2023 17:17:51 +0000
+Subject: [PATCH] build: Make building manpage dependent upon manpage option.
+
+---
+ data/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 41b94add..9042de80 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -27,7 +27,7 @@ endif
+ help2man = find_program('help2man', required: get_option('manpage'))
+ # help2man has to run zenity to generate the man page, which it can't do if
+ # we're cross building. We also can't tell help2man what exe wrapper to use.
+-if help2man.found() and not meson.is_cross_build()
++if help2man.found() and not meson.is_cross_build() and get_option('manpage')
+ help2man_opts = [
+ '--no-info',
+ '--section=1',
+--
+2.42.0
+
diff --git a/gnome-extra/zenity/zenity-3.99.2.ebuild b/gnome-extra/zenity/zenity-3.99.2.ebuild
new file mode 100644
index 000000000000..b940b30e3a79
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.99.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="man webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+ man? ( sys-apps/help2man )
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Make-help2man-depend-on-manpage-option.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ $(meson_use man manpage)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}