summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-01-08 01:44:15 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-01-24 19:30:55 +0200
commitfd9c5742eea0dc3daa007c6c22e379c5e4cd5327 (patch)
treedee36015c1c9a90ee58956196f434046beb31b3c /gnome-extra
parentgnome-extra/cinnamon-screensaver: 4.8.1 version bump (diff)
downloadgentoo-fd9c5742eea0dc3daa007c6c22e379c5e4cd5327.tar.gz
gentoo-fd9c5742eea0dc3daa007c6c22e379c5e4cd5327.tar.bz2
gentoo-fd9c5742eea0dc3daa007c6c22e379c5e4cd5327.zip
gnome-extra/cinnamon-settings-daemon: 4.8.5 version bump
Project was converted to meson. Bug: https://bugs.gentoo.org/757708 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon-settings-daemon/Manifest1
-rw-r--r--gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-4.8.5.ebuild93
-rw-r--r--gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-4.8.5-build-fixes.patch140
3 files changed, 234 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-settings-daemon/Manifest b/gnome-extra/cinnamon-settings-daemon/Manifest
index 23c2aa901c2f..747883e36393 100644
--- a/gnome-extra/cinnamon-settings-daemon/Manifest
+++ b/gnome-extra/cinnamon-settings-daemon/Manifest
@@ -1 +1,2 @@
DIST cinnamon-settings-daemon-4.6.4.tar.gz 668339 BLAKE2B 80e14d29a74004c1778e90d39c6ca892d3eee778134e43b8ea77cfec8cbad4f5ac21609cfbb9cdaab0b4d35b42e897223a5b9cdfd43de49d8112b8bc6fc45914 SHA512 77ddb637fd93fdfd59fb27c5a10082259fd99b4753ff36b3473db12f2fe0d19ee89d44c9e72f1ce9eab3f228c5fef418ce774dd78746d77b959ad9d8f93c1208
+DIST cinnamon-settings-daemon-4.8.5.tar.gz 662123 BLAKE2B b3ddd72e55c10c2cacc6dd29145e381395bd2ef68db7082a0770bb3eb647964041ed023d4a8357f2adcf5e8c9f8f713bac837809ed5926cc0434c2dc3e5c90ad SHA512 4a1d128b3f6faf3e2c13420d3569d4fd8cfaa1798ba5cf83fcb692662b9888d22f9f4bfb6fe18af59d0632583a2730a07e3ab48cca12c357b2d318d205fd7d0a
diff --git a/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-4.8.5.ebuild b/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-4.8.5.ebuild
new file mode 100644
index 000000000000..decd70b8dc19
--- /dev/null
+++ b/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-4.8.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson gnome2-utils xdg
+
+DESCRIPTION="Cinnamon's settings daemon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon-settings-daemon"
+SRC_URI="https://github.com/linuxmint/cinnamon-settings-daemon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+colord cups input_devices_wacom smartcard systemd"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ dev-libs/libgudev:=
+ >=gnome-base/libgnomekbd-3.6
+ >=gnome-extra/cinnamon-desktop-4.8:0=
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra:0=[gtk3,pulseaudio]
+ >=media-sound/pulseaudio-0.9.16[glib]
+ >=sys-apps/dbus-1.1.2
+ dev-libs/dbus-glib
+ >=sys-auth/polkit-0.97
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14.0:3
+ >=x11-libs/libnotify-0.7.3:0=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ >=x11-libs/libxklavier-5.0
+ >=sys-power/upower-0.9.11
+
+ colord? ( >=x11-misc/colord-0.1.27:= )
+ cups? (
+ >=net-print/cups-1.4[dbus]
+ app-admin/system-config-printer
+ net-print/cups-pk-helper )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7
+ >=gnome-base/librsvg-2.36.2
+ x11-drivers/xf86-input-wacom
+ x11-libs/libXtst )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ systemd? ( sys-apps/systemd:0= )
+ !systemd? ( sys-auth/elogind:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/libxml2:2
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.37.1
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Miscellaneous meson configuration/compilation fixes
+ # https://github.com/linuxmint/cinnamon-settings-daemon/pull/314
+ "${FILESDIR}/${PN}-4.8.5-build-fixes.patch"
+)
+
+src_configure() {
+ # gudev not optional on Linux platforms
+ local emesonargs=(
+ -Duse_gudev=enabled
+ -Duse_polkit=enabled
+ -Duse_logind=enabled
+ $(meson_feature colord use_color)
+ $(meson_feature cups use_cups)
+ $(meson_feature smartcard use_smartcard)
+ $(meson_feature input_devices_wacom use_wacom)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-4.8.5-build-fixes.patch b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-4.8.5-build-fixes.patch
new file mode 100644
index 000000000000..f70d1e544e94
--- /dev/null
+++ b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-4.8.5-build-fixes.patch
@@ -0,0 +1,140 @@
+From 281bc6b8e0085a91b7e59af45469c4da397646c2 Mon Sep 17 00:00:00 2001
+From: Sparky Bluefang <sparky@bluefang-logic.com>
+Date: Mon, 28 Dec 2020 17:05:21 -0500
+Subject: [PATCH] build: Add missing defines. Fix optional wacom build. Make
+ build options behave consistently.
+
+---
+ meson.build | 20 ++++++++++++--------
+ meson_options.txt | 14 ++++++++++----
+ plugins/meson.build | 2 +-
+ plugins/xrandr/meson.build | 1 +
+ 4 files changed, 24 insertions(+), 13 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 0e11d50..0d6c35a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -9,6 +9,7 @@ pkgname = meson.project_name().to_lower()
+ api_version = '3.0'
+
+ cc = meson.get_compiler('c')
++cargs = []
+
+ # directories
+ prefix = get_option('prefix')
+@@ -43,7 +44,7 @@ endif
+ cinnamon_desktop_required = '>= 4.8.0'
+ canberra = dependency('libcanberra-gtk3')
+ cinnamon_desktop = dependency('cinnamon-desktop', version: cinnamon_desktop_required)
+-colord = dependency('colord', version: '>= 0.1.27')
++colord = dependency('colord', version: '>= 0.1.27', required: get_option('use_color'))
+ cups = dependency('cups', version: '>= 1.4', required: get_option('use_cups'))
+ cvc = dependency('cvc', version: cinnamon_desktop_required)
+ fontconfig = dependency('fontconfig')
+@@ -56,13 +57,13 @@ gtk = dependency('gtk+-3.0', version: '>= 3.14.0')
+ gudev = dependency('gudev-1.0', required: get_option('use_gudev'))
+ libnotify = dependency('libnotify', version: '>= 0.7.3')
+ kbproto = dependency('kbproto')
+-nss = dependency('nss', version: '>= 3.11.2', required: get_option('enable_smartcard'))
++nss = dependency('nss', version: '>= 3.11.2', required: get_option('use_smartcard'))
+ polkit = dependency('polkit-gobject-1', version: '>= 0.97', required: get_option('use_polkit'))
+ pulse_required = '>= 0.9.16'
+ pulse = dependency('libpulse', version: pulse_required)
+ pulse_glib = dependency('libpulse-mainloop-glib', version: pulse_required)
+ upower_glib = dependency('upower-glib', version: '>= 0.9.11')
+-wacom = dependency('libwacom', version: '>= 0.7', required: false)
++wacom = dependency('libwacom', version: '>= 0.7', required: get_option('use_wacom'))
+ x11 = dependency('x11')
+ xext = dependency('xext')
+ xfixes = dependency('xfixes')
+@@ -80,13 +81,12 @@ librsvg = dependency('librsvg-2.0', version: '>= 2.36.2', required: wacom.found(
+ xorg_wacom = dependency('xorg-wacom', required: wacom.found())
+
+ lcms = dependency('lcms2', version: '>= 2.2', required: false)
+-has_new_lcms = lcms.found()
+-if not has_new_lcms
+- lcms = dependency('lcms2')
++if lcms.found()
++ cargs += '-DHAVE_NEW_LCMS'
++else
++ lcms = dependency('lcms2', required: colord.found())
+ endif
+
+-cargs = []
+-
+ using_logind = false
+ if not get_option('use_logind').disabled()
+ logind = dependency('libsystemd-logind', required: false)
+@@ -125,6 +125,10 @@ if gudev.found()
+ cargs += '-DHAVE_GUDEV'
+ endif
+
++if wacom.found()
++ cargs += '-DHAVE_WACOM'
++endif
++
+ if not get_option('enable_debug')
+ cargs += [
+ '-Wno-deprecated-declarations',
+diff --git a/meson_options.txt b/meson_options.txt
+index 0a6941b..e3c89f3 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -35,20 +35,26 @@ option(
+ description: 'Whether cups (and therefore the print notifications plugin) support should be enabled'
+ )
+ option(
+- 'enable_smartcard',
++ 'use_smartcard',
+ type: 'feature',
+ value: 'enabled',
+ description: 'Set to false to disable smartcard support'
+ )
+ option(
+ 'use_color',
+- type: 'boolean',
+- value: true,
++ type: 'feature',
++ value: 'enabled',
+ description: 'Whether the color plugin should be enabled'
+ )
++option(
++ 'use_wacom',
++ type: 'feature',
++ value: 'auto',
++ description: 'Whether the wacom plugin should be enabled'
++)
+ option(
+ 'enable_debug',
+ type: 'boolean',
+ value: false,
+ description: 'Show additional build warnings'
+-)
+\ No newline at end of file
++)
+diff --git a/plugins/meson.build b/plugins/meson.build
+index 0d11a52..069366d 100644
+--- a/plugins/meson.build
++++ b/plugins/meson.build
+@@ -24,7 +24,7 @@ subdir('sound')
+ subdir('xrandr')
+ subdir('xsettings')
+
+-if get_option('use_color')
++if colord.found()
+ subdir('color')
+ endif
+
+diff --git a/plugins/xrandr/meson.build b/plugins/xrandr/meson.build
+index db2bf73..3296f1a 100644
+--- a/plugins/xrandr/meson.build
++++ b/plugins/xrandr/meson.build
+@@ -11,6 +11,7 @@ xrandr_deps = [
+ csd_dep,
+ libnotify,
+ upower_glib,
++ wacom,
+ xfixes,
+ ]
+