summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/gnumail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/gnumail')
-rw-r--r--gnustep-apps/gnumail/Manifest2
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.0.ebuild81
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.2.ebuild35
-rw-r--r--gnustep-apps/gnumail/metadata.xml14
4 files changed, 132 insertions, 0 deletions
diff --git a/gnustep-apps/gnumail/Manifest b/gnustep-apps/gnumail/Manifest
new file mode 100644
index 000000000000..75916bf026bc
--- /dev/null
+++ b/gnustep-apps/gnumail/Manifest
@@ -0,0 +1,2 @@
+DIST GNUMail-1.2.0.tar.gz 1380032 SHA256 792512276b253d79362736fb0cb7d614d5a980ea356d03d6adec4d0dd0f6ef2c SHA512 ef0c806e5550daa064a789633c3ecb87819c1e94667fc69fc52bc2923a6819ac6e7fc5262a74503c3554e79429c3d2163eeb68fd30adcfe59ba3aede7ee0a7cb WHIRLPOOL 8fb58c22ff2a2b0a8949aefcbe16c943287069e96d0ff0543156065c7d15e5c0b781497b7f6d3d01f609a3d2ff3010437bc5353ca233cc0b06a9d704374442df
+DIST GNUMail-1.2.2.tar.gz 1397764 SHA256 31a0c34c3afe20afb6b8ebc41002d2f9dbc2134ceda2032e67e64cb7d884d8af SHA512 3243c51eb177c1fabeeb894e6231e5ace09fb08fd0eb9d6311726bdebddc743e3b3958b4c00597e7eb97de7c2a25f1ca7e8f4111e7d543ecd65ee5f35bea89cc WHIRLPOOL 75dc05440ce08962cd5376d8faca143fb38dea77d4d6adec2e6a6eeffb2e9088b498404f6a80a1328200853b756b3215eb7049247a72a2972d7dec9390697dbe
diff --git a/gnustep-apps/gnumail/gnumail-1.2.0.ebuild b/gnustep-apps/gnumail/gnumail-1.2.0.ebuild
new file mode 100644
index 000000000000..fc1b9db9ffd6
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt +emoticon +xface"
+DEPEND=">=gnustep-base/gnustep-gui-0.11.0
+ =gnustep-libs/pantomime-1.2*
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ sed -i -e 's|GNUMail_GUI_LIBS =|LIBRARIES_DEPEND_UPON +=|' \
+ Framework/GNUMail/GNUmakefile || die "as-needed sed failed"
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make
+
+ cd Bundles/Clock
+ egnustep_make
+ cd "${S}"
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_make
+ cd "${S}"
+ fi
+
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_make
+ cd "${S}"
+ fi
+
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_make
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd Bundles/Clock
+ egnustep_install
+ cd "${S}"
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_install
+ cd "${S}"
+ fi
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_install
+ cd "${S}"
+ fi
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_install
+ cd "${S}"
+ fi
+
+ dodoc "${S}"/Documentation/*
+}
diff --git a/gnustep-apps/gnumail/gnumail-1.2.2.ebuild b/gnustep-apps/gnumail/gnumail-1.2.2.ebuild
new file mode 100644
index 000000000000..aef43816d883
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt"
+DEPEND=">=gnustep-base/gnustep-gui-0.11.0
+ =gnustep-libs/pantomime-1.2*
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ sed -i -e 's|GNUMail_GUI_LIBS =|LIBRARIES_DEPEND_UPON +=|' \
+ Framework/GNUMail/GNUmakefile || die "as-needed sed failed"
+ use crypt || sed -i -e 's|Bundles/PGP||' \
+ GNUmakefile || die "PGP bundle sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc "${S}"/Documentation/*
+}
diff --git a/gnustep-apps/gnumail/metadata.xml b/gnustep-apps/gnumail/metadata.xml
new file mode 100644
index 000000000000..0271db4640d6
--- /dev/null
+++ b/gnustep-apps/gnumail/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+GNUMail.app is a fully featured mail application running on Linux (or FreeBSD, OpenBSD, etc) and Apple Mac OS X. It uses the GNUstep development framework or Apple Cocoa, which is based on the OpenStep specification provided by NeXT, Inc.. GNUMail.app is licensed under the GPL, and the full sources of the application are available.
+
+GNUMail.app was written from scratch. It uses Pantomime as its mail handling framework.
+</longdescription>
+<use>
+ <flag name='emoticon'>Enable extra Emoticon Bundle to see smiley's in e-mail
+ messages</flag>
+</use>
+</pkgmetadata>