summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-09-23 18:29:41 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-09-23 18:38:54 +0200
commit286745762d04d527711bdc41b4b2392560ecffd4 (patch)
treee8642736030b74429f51050162bf0d1aae1120ce /gnustep-apps/sogo
parentpackage.mask: revert dev-libs/libwbxml mask (diff)
downloadgentoo-286745762d04d527711bdc41b4b2392560ecffd4.tar.gz
gentoo-286745762d04d527711bdc41b4b2392560ecffd4.tar.bz2
gentoo-286745762d04d527711bdc41b4b2392560ecffd4.zip
gnustep-apps/sogo: 4.0.8 bump, fix activesync support
Closes: https://bugs.gentoo.org/693680 Closes: https://bugs.gentoo.org/685788 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-apps/sogo')
-rw-r--r--gnustep-apps/sogo/Manifest1
-rw-r--r--gnustep-apps/sogo/sogo-4.0.8.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
index bf31fa483b72..0f0cbee7e0cb 100644
--- a/gnustep-apps/sogo/Manifest
+++ b/gnustep-apps/sogo/Manifest
@@ -1,3 +1,4 @@
DIST sogo-3.2.10.tar.gz 32528115 BLAKE2B 7543f2165ed20026f00adfac7697fe6bc0e54f06b3c2ccb99fbfe0ddd14bcf8818521e161bb118789175c4245b67a8ad5dd0cd3ef71f61d34d869e1c0c2a4a93 SHA512 3dbd465592fd98968b32e251659a70306a781999bcfa9e63e142d75d7c9274edc7cbe5069881e939f0e9472f0ef8580e4e0f20059bfc97f8c69893d86c8cadf3
DIST sogo-3.2.9.tar.gz 32443733 BLAKE2B 6a2ae4b5346bc48b9301263fe017308ee34aabcee1ce5444744b22c3af040533d98738fca29a195fd0f792d1d4470418840d0b1ff0e264c2ebc92877f420fa75 SHA512 070b3812d65598364d9204432678ea48705bf7481371e44442a13ad86d219415e24c579ad59212a7631922a527d30e69aeb17711c3abfc01960f663f4e0112a3
DIST sogo-4.0.7.tar.gz 34455581 BLAKE2B 471ae8fc503fb2282cbd585286c0eede4e91e14bd9314a02089ffb0c69a8453538902cc26a4ebfdcacdce3d90f2d640221e1b452ad4b6a8064de89b1694eee7e SHA512 8e7eb946ab6ad8c47e6b612723675704602199b530c760ded5325f1230d89e7a812a61d9e652c7eca3050ed0bd0dd33d95faf2478f58a82dcba745cce4906675
+DIST sogo-4.0.8.tar.gz 34439405 BLAKE2B 603ef52d305c13e2d5d200b53143771ceb762c97f4f6e09aff31091f482bb43fa2638f88fcd676770b55da6e85c072dbf884c8cce20d2a71c8d62d0a98e30089 SHA512 7f8d7e3af2c92d7684f2ce3343fd9c079d567e2f09fc5ae1405e46b8eee460ab8e4349c03020bc8e55993472021633f9e37d3d8c3136a485dff1d32f45ba200a
diff --git a/gnustep-apps/sogo/sogo-4.0.8.ebuild b/gnustep-apps/sogo/sogo-4.0.8.ebuild
new file mode 100644
index 000000000000..eb6d96d450d2
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-4.0.8.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="activesync gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ activesync? ( dev-libs/libwbxml )
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewgroup sogo
+ enewuser sogo -1 /bin/bash /var/lib/sogo sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die
+ if use activesync; then
+ sed -e 's/Tests\/Unit/ActiveSync &/g' \
+ -i GNUmakefile || die
+ fi
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+ if use activesync; then
+ ewarn "In order to use the SOGo ActiveSync support code in production environments,"
+ ewarn "you need to get a proper usage license. Check the documentation for details."
+ fi
+}