summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-05-31 14:10:43 +0200
committerMichael Weber <xmw@gentoo.org>2017-05-31 14:30:23 +0200
commit388e6389a161565f1f3cc262a223088555c80a5d (patch)
treebc5d339a3b49297981f0818fdc9be6a2fb7b5df0 /gnustep-libs/sope/sope-3.2.9.ebuild
parentmail-filter/rspamd: correct distfile. (diff)
downloadgentoo-388e6389a161565f1f3cc262a223088555c80a5d.tar.gz
gentoo-388e6389a161565f1f3cc262a223088555c80a5d.tar.bz2
gentoo-388e6389a161565f1f3cc262a223088555c80a5d.zip
gnustep-libs/sope: Version bump (bug 620084).
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'gnustep-libs/sope/sope-3.2.9.ebuild')
-rw-r--r--gnustep-libs/sope/sope-3.2.9.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnustep-libs/sope/sope-3.2.9.ebuild b/gnustep-libs/sope/sope-3.2.9.ebuild
new file mode 100644
index 000000000000..550358b4884d
--- /dev/null
+++ b/gnustep-libs/sope/sope-3.2.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnustep-2 vcs-snapshot
+
+DESCRIPTION="A set of frameworks forming a complete Web application server environment"
+HOMEPAGE="http://www.sogo.nu/"
+SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
+
+RDEPEND="
+ sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ mysql? ( virtual/libmysqlclient:= )
+ postgres? ( dev-db/postgresql:= )
+ xml? ( dev-libs/libxml2:2 )
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ # Non-standard configure script
+ ./configure \
+ --disable-strip \
+ $(use_enable debug) \
+ $(use_enable ldap openldap) \
+ $(use_enable mysql) \
+ $(use_enable postgres postgresql) \
+ $(use_enable xml) \
+ --with-ssl="${ssl_provider}" \
+ --with-gnustep || die "configure failed"
+}