summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-02-22 17:35:51 -0500
committerAaron Bauman <bman@gentoo.org>2019-02-22 17:35:51 -0500
commit97aba5400b89ac05a73194209a48f48cb03611e6 (patch)
treed5a8ab72bdc7ed443e514842a36bb9b6fd426ba1 /gui-apps/swayidle/swayidle-9999.ebuild
parentdev-libs/sway{idle,lock}: drop and move to gui-apps/ (diff)
downloadgentoo-97aba5400b89ac05a73194209a48f48cb03611e6.tar.gz
gentoo-97aba5400b89ac05a73194209a48f48cb03611e6.tar.bz2
gentoo-97aba5400b89ac05a73194209a48f48cb03611e6.zip
gui-apps/sway{idle,lock}: add new category and move packages
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/swayidle/swayidle-9999.ebuild')
-rw-r--r--gui-apps/swayidle/swayidle-9999.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/gui-apps/swayidle/swayidle-9999.ebuild b/gui-apps/swayidle/swayidle-9999.ebuild
new file mode 100644
index 000000000000..774758c9815e
--- /dev/null
+++ b/gui-apps/swayidle/swayidle-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Idle management daemon for Wayland"
+HOMEPAGE="https://github.com/swaywm/swayidle"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind fish-completion +man systemd zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/wayland
+ elogind? ( >=sys-auth/elogind-237[policykit] )
+ systemd? ( >=sys-apps/systemd-237[policykit] )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/sway-1.0_beta1
+ !~dev-libs/sway-1.0_beta2[swayidle]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}