summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-18 19:57:53 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-05 21:56:32 -0400
commit5e95b1f9ac84775b95ce31f7c85b61fbdef8952c (patch)
tree40fefa36637e66765beffae7643a44c416661e37 /gui-apps/wf-shell
parentgui-apps/lavalauncher: new wayland application launcher (diff)
downloadgentoo-5e95b1f9ac84775b95ce31f7c85b61fbdef8952c.tar.gz
gentoo-5e95b1f9ac84775b95ce31f7c85b61fbdef8952c.tar.bz2
gentoo-5e95b1f9ac84775b95ce31f7c85b61fbdef8952c.zip
gui-wm/wayfire: fix dependency versioning for building
Closes: https://bugs.gentoo.org/723760 added proper dependency versions of wlroots also changed options to src_configure instead of src_compile as per standard convention not version bumping as this fixes compile bugs and no runtime changes Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15875 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/wf-shell')
-rw-r--r--gui-apps/wf-shell/wf-shell-0.4.0.ebuild6
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/gui-apps/wf-shell/wf-shell-0.4.0.ebuild b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
index 9167682d0b61..ab448db2642f 100644
--- a/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
+++ b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
@@ -23,7 +23,7 @@ IUSE="+pulseaudio debug"
DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
- ~gui-wm/wayfire-${PV}
+ ~gui-wm/wayfire-${PV}[debug=]
>=gui-libs/gtk-layer-shell-0.1
pulseaudio? ( media-sound/pulseaudio )
"
@@ -36,7 +36,7 @@ BDEPEND="
virtual/pkgconfig
"
-src_compile () {
+src_configure () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
)
@@ -45,5 +45,5 @@ src_compile () {
"-Db_sanitize=address,undefined"
)
fi
- meson_src_compile
+ meson_src_configure
}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
index 9167682d0b61..ab448db2642f 100644
--- a/gui-apps/wf-shell/wf-shell-9999.ebuild
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -23,7 +23,7 @@ IUSE="+pulseaudio debug"
DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
- ~gui-wm/wayfire-${PV}
+ ~gui-wm/wayfire-${PV}[debug=]
>=gui-libs/gtk-layer-shell-0.1
pulseaudio? ( media-sound/pulseaudio )
"
@@ -36,7 +36,7 @@ BDEPEND="
virtual/pkgconfig
"
-src_compile () {
+src_configure () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
)
@@ -45,5 +45,5 @@ src_compile () {
"-Db_sanitize=address,undefined"
)
fi
- meson_src_compile
+ meson_src_configure
}