summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <meurerbernardo@gmail.com>2019-08-03 20:39:40 -0700
committerAaron Bauman <bman@gentoo.org>2019-08-08 20:19:18 -0400
commit18a65ca991f7dbce9a30a744df203e3e8d200124 (patch)
tree78ba98ff0f322e64cd1ddc50e43dbd8514c1a7dc /gui-apps
parentgui-apps/grim: New package (1.2.0, 9999) (diff)
downloadgentoo-18a65ca991f7dbce9a30a744df203e3e8d200124.tar.gz
gentoo-18a65ca991f7dbce9a30a744df203e3e8d200124.tar.bz2
gentoo-18a65ca991f7dbce9a30a744df203e3e8d200124.zip
gui-apps/slurp: New package (1.2.0, 9999)
Closes: https://bugs.gentoo.org/684710 Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Closes: https://github.com/gentoo/gentoo/pull/12614 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/slurp/Manifest1
-rw-r--r--gui-apps/slurp/metadata.xml23
-rw-r--r--gui-apps/slurp/slurp-1.2.0.ebuild43
-rw-r--r--gui-apps/slurp/slurp-9999.ebuild41
4 files changed, 108 insertions, 0 deletions
diff --git a/gui-apps/slurp/Manifest b/gui-apps/slurp/Manifest
new file mode 100644
index 000000000000..a07473c5b6e2
--- /dev/null
+++ b/gui-apps/slurp/Manifest
@@ -0,0 +1 @@
+DIST slurp-1.2.0.tar.gz 15317 BLAKE2B 92de74abb54b2d53334e0f0c5d08b0b50e9c4583eb192226e38fcefa07cce2265f808ce81c04170e65d3c1209fa263352e3d70cc0a7cf745ed5e18d57c4d3af6 SHA512 443cd497049a5128e80a48c7b2afcc555a8d58a5eacc2dc6207058a9a399bc9e9804c7bca8b010af63f8be99000c05245720bd3e8cca248a74d5aa63a7faf4f9
diff --git a/gui-apps/slurp/metadata.xml b/gui-apps/slurp/metadata.xml
new file mode 100644
index 000000000000..4f4fa04fe663
--- /dev/null
+++ b/gui-apps/slurp/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Select a region in a Wayland compositor and print it to the standard output.
+ </longdescription>
+ <use>
+ <flag name="man">Generate and install man pages.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emersion/slurp</remote-id>
+ <bugs-to>https://github.com/emersion/slurp/issues</bugs-to>
+ <changelog>https://github.com/emersion/slurp/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/slurp/slurp-1.2.0.ebuild b/gui-apps/slurp/slurp-1.2.0.ebuild
new file mode 100644
index 000000000000..0374876964f1
--- /dev/null
+++ b/gui-apps/slurp/slurp-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/slurp/slurp-9999.ebuild b/gui-apps/slurp/slurp-9999.ebuild
new file mode 100644
index 000000000000..20fa33ff1cb8
--- /dev/null
+++ b/gui-apps/slurp/slurp-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}