summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-06 16:02:58 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-06 20:12:15 -0400
commit3219011cd3b0b1fa85974a1b5563efe260406adc (patch)
tree219476526ce1279f660a0bd5a0d156ade9aac16d /gui-apps
parentgui-wm/wayfire: remove debug symbols (diff)
downloadgentoo-3219011cd3b0b1fa85974a1b5563efe260406adc.tar.gz
gentoo-3219011cd3b0b1fa85974a1b5563efe260406adc.tar.bz2
gentoo-3219011cd3b0b1fa85974a1b5563efe260406adc.zip
gui-apps/wcm: remove debug symbols
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wcm/wcm-0.4.0-r1.ebuild (renamed from gui-apps/wcm/wcm-0.4.0.ebuild)17
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild17
2 files changed, 6 insertions, 28 deletions
diff --git a/gui-apps/wcm/wcm-0.4.0.ebuild b/gui-apps/wcm/wcm-0.4.0-r1.ebuild
index b59aeb831706..54d7e4cee824 100644
--- a/gui-apps/wcm/wcm-0.4.0.ebuild
+++ b/gui-apps/wcm/wcm-0.4.0-r1.ebuild
@@ -10,21 +10,20 @@ HOMEPAGE="https://github.com/WayfireWM/wcm"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
else
- SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
dev-cpp/gtkmm:3.0[wayland]
- ~gui-wm/wayfire-${PV}[debug=]
+ ~gui-wm/wayfire-${PV}
"
RDEPEND="${DEPEND}"
@@ -34,13 +33,3 @@ BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
"
-
-src_configure() {
- local emesonargs=""
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
- meson_src_configure
-}
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index b59aeb831706..54d7e4cee824 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -10,21 +10,20 @@ HOMEPAGE="https://github.com/WayfireWM/wcm"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
else
- SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
dev-cpp/gtkmm:3.0[wayland]
- ~gui-wm/wayfire-${PV}[debug=]
+ ~gui-wm/wayfire-${PV}
"
RDEPEND="${DEPEND}"
@@ -34,13 +33,3 @@ BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
"
-
-src_configure() {
- local emesonargs=""
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
- meson_src_configure
-}