summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-15 11:55:19 -0400
committerAaron Bauman <bman@gentoo.org>2020-05-17 11:54:36 -0400
commit3713d3b1fb431a194478075fb408aa9301e44018 (patch)
tree344a97a0c33a0786284c17fa4ea2d279b8022393 /gui-apps
parentgui-wm/wayfire: compiz like 3d wayland manager (diff)
downloadgentoo-3713d3b1fb431a194478075fb408aa9301e44018.tar.gz
gentoo-3713d3b1fb431a194478075fb408aa9301e44018.tar.bz2
gentoo-3713d3b1fb431a194478075fb408aa9301e44018.zip
gui-apps/wcm: wayfire config manager
Closes: https://bugs.gentoo.org/713884 configuration parser and generator, which allows you to reload the config on the fly without needing to restart wayfire Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/metadata.xml17
-rw-r--r--gui-apps/wcm/wcm-0.4.0.ebuild46
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild46
4 files changed, 110 insertions, 0 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
new file mode 100644
index 000000000000..ec440af0389f
--- /dev/null
+++ b/gui-apps/wcm/Manifest
@@ -0,0 +1 @@
+DIST wcm-0.4.0.tar.gz 263841 BLAKE2B 28cdf87c479cc7a4a5a40f17a1ec26688bae6a0cd5699b51ad7db2adca89946d7687ae345a7a82d71464df413c956aceeb3db8195c5b40da5f32043821883c49 SHA512 4136ceba90c054165b4b0e7a79d78af827d8b8ddb8b54820bda0c17bbaa28eb74981ce94d8c386b91257ca023a34f76f121a003229365afe72d65323f0a1d2cd
diff --git a/gui-apps/wcm/metadata.xml b/gui-apps/wcm/metadata.xml
new file mode 100644
index 000000000000..692d4fe3fd2e
--- /dev/null
+++ b/gui-apps/wcm/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ GUI front end to the wayfire config manager.
+ Allows to reload changes on the fly without
+ needing to restart wayfire.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wcm/wcm-0.4.0.ebuild b/gui-apps/wcm/wcm-0.4.0.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}