summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-03-04 06:17:18 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-04 14:26:08 +0200
commitc638628292d79e6a7612434e5e1caabcba13ef46 (patch)
tree05350ea98a6112383cc5f6632533bb7be5f61231 /gui-apps
parentsys-kernel/gentoo-sources: Linux patch 4.19.178 (diff)
downloadgentoo-c638628292d79e6a7612434e5e1caabcba13ef46.tar.gz
gentoo-c638628292d79e6a7612434e5e1caabcba13ef46.tar.bz2
gentoo-c638628292d79e6a7612434e5e1caabcba13ef46.zip
gui-apps/swappy: fix werror for meson build
Closes: https://bugs.gentoo.org/774162 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/19762 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swappy/swappy-1.3.1.ebuild8
-rw-r--r--gui-apps/swappy/swappy-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/gui-apps/swappy/swappy-1.3.1.ebuild b/gui-apps/swappy/swappy-1.3.1.ebuild
index 7ece9d81f145..eea557b615f4 100644
--- a/gui-apps/swappy/swappy-1.3.1.ebuild
+++ b/gui-apps/swappy/swappy-1.3.1.ebuild
@@ -40,6 +40,14 @@ src_prepare() {
sed -i -e 's/Utility;Graphics;Annotation;/Utility;Graphics;/' src/po/swappy.desktop.in || die "Sed failed!"
}
+src_configure() {
+ local emesonargs=(
+ -Dwerror=false
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
pkg_postinst() {
xdg_pkg_postinst
diff --git a/gui-apps/swappy/swappy-9999.ebuild b/gui-apps/swappy/swappy-9999.ebuild
index 7ece9d81f145..eea557b615f4 100644
--- a/gui-apps/swappy/swappy-9999.ebuild
+++ b/gui-apps/swappy/swappy-9999.ebuild
@@ -40,6 +40,14 @@ src_prepare() {
sed -i -e 's/Utility;Graphics;Annotation;/Utility;Graphics;/' src/po/swappy.desktop.in || die "Sed failed!"
}
+src_configure() {
+ local emesonargs=(
+ -Dwerror=false
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
pkg_postinst() {
xdg_pkg_postinst