summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-18 07:51:29 -0400
committerAaron Bauman <bman@gentoo.org>2020-05-18 17:37:25 -0400
commitc6bbd5cfd19942ce6027b04ed10d9345ddfbc432 (patch)
treefafb20eaf47d328c43792803012fa04a485619b1 /gui-apps
parentwww-plugins/chrome-binary-plugins: automated update (83.0.4103.61) (diff)
downloadgentoo-c6bbd5cfd19942ce6027b04ed10d9345ddfbc432.tar.gz
gentoo-c6bbd5cfd19942ce6027b04ed10d9345ddfbc432.tar.bz2
gentoo-c6bbd5cfd19942ce6027b04ed10d9345ddfbc432.zip
gui-apps/kanshi: autorandr for wayland clients
Closes: https://bugs.gentoo.org/723746 kanshi allows you to define output profiles that are automatically enabled and disabled on hotplug. For instance, this can be used to turn a laptop's internal screen off when docked. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15865 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/kanshi/Manifest1
-rw-r--r--gui-apps/kanshi/kanshi-1.1.0.ebuild43
-rw-r--r--gui-apps/kanshi/kanshi-9999.ebuild43
-rw-r--r--gui-apps/kanshi/metadata.xml13
4 files changed, 100 insertions, 0 deletions
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
new file mode 100644
index 000000000000..8c0196576167
--- /dev/null
+++ b/gui-apps/kanshi/Manifest
@@ -0,0 +1 @@
+DIST kanshi-1.1.0.tar.gz 15884 BLAKE2B 1085e9d8f3ff53f78cb248941269713fd7ea38c60ad0e9816acb902f171b6f945af521a3835fc9db479620e6031483f6dbab5cfc507872dcabdfbcf9d6711269 SHA512 6582bae7b73ad13cad83e4d537c7c870699a72bf6993becaafa47a3dd70439a3c626ffff4874c8f737b32b62ad7512772c2c3bf54ac2cb74879213bd40b8d7a1
diff --git a/gui-apps/kanshi/kanshi-1.1.0.ebuild b/gui-apps/kanshi/kanshi-1.1.0.ebuild
new file mode 100644
index 000000000000..221a5f5f59ed
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/kanshi/kanshi-9999.ebuild b/gui-apps/kanshi/kanshi-9999.ebuild
new file mode 100644
index 000000000000..221a5f5f59ed
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/kanshi/metadata.xml b/gui-apps/kanshi/metadata.xml
new file mode 100644
index 000000000000..21d7750ccd0e
--- /dev/null
+++ b/gui-apps/kanshi/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ kanshi allows you to define output profiles that
+ are automatically enabled and disabled on hotplug.
+ For instance, this can be used to turn a laptop's
+ internal screen off when docked.
+ </longdescription>
+ <use>
+ <flag name="man">build and install man pages</flag>
+ </use>
+</pkgmetadata>