summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmily Mills <emily@emlove.me>2020-12-14 11:52:20 -0600
committerJoonas Niilola <juippis@gentoo.org>2021-03-04 08:00:59 +0200
commite41796ba608f0e9c578acdd20a733d7082b4a775 (patch)
tree57f7bf4e0018808777744248ee396ca3757b4a16 /gui-apps
parentnet-p2p/eiskaltdcpp: Bump to 2.4.2 (diff)
downloadgentoo-e41796ba608f0e9c578acdd20a733d7082b4a775.tar.gz
gentoo-e41796ba608f0e9c578acdd20a733d7082b4a775.tar.bz2
gentoo-e41796ba608f0e9c578acdd20a733d7082b4a775.zip
gui-apps/swappy: Wayland native snapshot tool
Allows editing and modifying snapshots along with support for other native wayland tools like grim and wl-clipboard Signed-off-by: Emily Mills <emily@emlove.me> Closes: https://github.com/gentoo/gentoo/pull/18652 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swappy/Manifest1
-rw-r--r--gui-apps/swappy/metadata.xml16
-rw-r--r--gui-apps/swappy/swappy-1.3.1.ebuild51
-rw-r--r--gui-apps/swappy/swappy-9999.ebuild51
4 files changed, 119 insertions, 0 deletions
diff --git a/gui-apps/swappy/Manifest b/gui-apps/swappy/Manifest
new file mode 100644
index 000000000000..01640aea1202
--- /dev/null
+++ b/gui-apps/swappy/Manifest
@@ -0,0 +1 @@
+DIST swappy-1.3.1.tar.gz 650917 BLAKE2B 7d1334414b5c4a7b0b53adbb40c5757398283dc0f3815ff5f4d2db6dd35d650b7e89e70663eaf7a0e111fadfcfe19e57af6a27037047f82f923409a77e44bdb6 SHA512 0d6a3ae9ed2595795ecff22fcc90640e416a1e34f11129146bb49642b4db58c615c29c1d4dcc964cc371545e73e64e99e48d1ddd0e8f36280158b649613a1693
diff --git a/gui-apps/swappy/metadata.xml b/gui-apps/swappy/metadata.xml
new file mode 100644
index 000000000000..4d6892c98d9e
--- /dev/null
+++ b/gui-apps/swappy/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>emily@emlove.me</email>
+ <name>Emily Mills</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/swappy/swappy-1.3.1.ebuild b/gui-apps/swappy/swappy-1.3.1.ebuild
new file mode 100644
index 000000000000..42287fc7bf8c
--- /dev/null
+++ b/gui-apps/swappy/swappy-1.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/cairo
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_prepare() {
+ eapply_user
+
+ # See https://github.com/jtheoof/swappy/pull/99
+ sed -i -e 's/Utility;Graphics;Annotation;/Utility;Graphics;/' src/po/swappy.desktop.in || die "Sed failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/gui-apps/swappy/swappy-9999.ebuild b/gui-apps/swappy/swappy-9999.ebuild
new file mode 100644
index 000000000000..42287fc7bf8c
--- /dev/null
+++ b/gui-apps/swappy/swappy-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/cairo
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_prepare() {
+ eapply_user
+
+ # See https://github.com/jtheoof/swappy/pull/99
+ sed -i -e 's/Utility;Graphics;Annotation;/Utility;Graphics;/' src/po/swappy.desktop.in || die "Sed failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}