summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-25 04:04:10 +0100
committerSam James <sam@gentoo.org>2021-07-31 01:16:59 +0100
commitf13835cb87bdbf99bb75c37024739e339049c15d (patch)
treead3b62ce02e435cbdd17f6a9a56fd68f7b73b8c0 /gui-apps
parentgui-apps/swaylock: [QA] unconditionally install completion files (diff)
downloadgentoo-f13835cb87bdbf99bb75c37024739e339049c15d.tar.gz
gentoo-f13835cb87bdbf99bb75c37024739e339049c15d.tar.bz2
gentoo-f13835cb87bdbf99bb75c37024739e339049c15d.zip
gui-apps/swayidle: [QA] unconditionally install completion files
QA policy [0] says that we don't conditionalise installation of small files. It's a wasteful rebuild and inconsistent across packages for when users desire completions to be available. [0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swayidle/metadata.xml1
-rw-r--r--gui-apps/swayidle/swayidle-1.6.ebuild7
-rw-r--r--gui-apps/swayidle/swayidle-9999.ebuild8
3 files changed, 8 insertions, 8 deletions
diff --git a/gui-apps/swayidle/metadata.xml b/gui-apps/swayidle/metadata.xml
index 91ff1890bc12..4c7034b2aaff 100644
--- a/gui-apps/swayidle/metadata.xml
+++ b/gui-apps/swayidle/metadata.xml
@@ -15,7 +15,6 @@
</longdescription>
<use>
<flag name="elogind">Enable support for rootless session via elogind</flag>
- <flag name="fish-completion">Enable fish completion support</flag>
</use>
<upstream>
<remote-id type="github">swaywm/swayidle</remote-id>
diff --git a/gui-apps/swayidle/swayidle-1.6.ebuild b/gui-apps/swayidle/swayidle-1.6.ebuild
index ae2ed9985b48..94194af2e4ae 100644
--- a/gui-apps/swayidle/swayidle-1.6.ebuild
+++ b/gui-apps/swayidle/swayidle-1.6.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind fish-completion +man systemd zsh-completion"
+IUSE="elogind +man systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -36,11 +36,12 @@ BDEPEND="
src_configure() {
local emesonargs=(
-Dman-pages=$(usex man enabled disabled)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
"-Dbash-completions=true"
"-Dwerror=false"
)
+
if use systemd; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
elif use elogind; then
diff --git a/gui-apps/swayidle/swayidle-9999.ebuild b/gui-apps/swayidle/swayidle-9999.ebuild
index 8604bda55107..f6abc2bf7237 100644
--- a/gui-apps/swayidle/swayidle-9999.ebuild
+++ b/gui-apps/swayidle/swayidle-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind fish-completion +man systemd zsh-completion"
+IUSE="elogind +man systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -36,8 +36,8 @@ BDEPEND="
src_configure() {
local emesonargs=(
-Dman-pages=$(usex man enabled disabled)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
"-Dbash-completions=true"
"-Dwerror=false"
)