summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-09 11:43:47 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-06-11 17:23:30 +0300
commitf37f8e32f3ae8fc479291919570ac681d35c7ece (patch)
tree8bb7325e64234c9b494499f620104b83c6f66265 /gui-apps
parentgui-apps/wf-recorder: dependency use flag fixes (diff)
downloadgentoo-f37f8e32f3ae8fc479291919570ac681d35c7ece.tar.gz
gentoo-f37f8e32f3ae8fc479291919570ac681d35c7ece.tar.bz2
gentoo-f37f8e32f3ae8fc479291919570ac681d35c7ece.zip
gui-apps/wf-recorder: live ebuild added
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15919 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-recorder/wf-recorder-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gui-apps/wf-recorder/wf-recorder-9999.ebuild b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
new file mode 100644
index 000000000000..6bc50719fea0
--- /dev/null
+++ b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Screen recorder for wlroots-based compositors"
+HOMEPAGE="https://github.com/ammen99/wf-recorder"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
+else
+ SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man opencl"
+
+DEPEND="
+ dev-libs/wayland
+ media-sound/pulseaudio
+ media-video/ffmpeg[opencl?,pulseaudio,x264]
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+ man? ( >=app-text/scdoc-1.9.3 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature opencl)
+ )
+ meson_src_configure
+}