summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-31 12:45:26 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-31 12:45:35 +0200
commit94caacc98ca0fe4fc8d8b5889bbab57c17a0bc07 (patch)
treebf634b509d8906f04c47be10d9995dfdd119b0a9 /gui-libs/amtk/amtk-5.0.2.ebuild
parentdev-python/hypothesis: Remove redundant versions (diff)
downloadgentoo-94caacc98ca0fe4fc8d8b5889bbab57c17a0bc07.tar.gz
gentoo-94caacc98ca0fe4fc8d8b5889bbab57c17a0bc07.tar.bz2
gentoo-94caacc98ca0fe4fc8d8b5889bbab57c17a0bc07.zip
gui-libs/amtk: bump to 5.0.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs/amtk/amtk-5.0.2.ebuild')
-rw-r--r--gui-libs/amtk/amtk-5.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-libs/amtk/amtk-5.0.2.ebuild b/gui-libs/amtk/amtk-5.0.2.ebuild
new file mode 100644
index 000000000000..2b48a6677c9e
--- /dev/null
+++ b/gui-libs/amtk/amtk-5.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Actions, Menus and Toolbars Kit for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/Amtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+ >=sys-devel/gettext-0.19.6
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gtk-doc \
+ --disable-installed-tests \
+ $(use_enable introspection) \
+ --disable-valgrind
+}