summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-03-21 18:20:16 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-21 18:20:16 +0100
commit264f42fd95eb16cd50654446fc78309fc24bd0ab (patch)
tree8adf0b734cb62322d0e19a7c28624dd30b09928f /gui-libs/egl-wayland
parentapp-misc/xmind: Fix typo (diff)
downloadgentoo-264f42fd95eb16cd50654446fc78309fc24bd0ab.tar.gz
gentoo-264f42fd95eb16cd50654446fc78309fc24bd0ab.tar.bz2
gentoo-264f42fd95eb16cd50654446fc78309fc24bd0ab.zip
gui-libs/egl-wayland: don't use -Werror for build
Closes: https://github.com/gentoo/gentoo/pull/20037 Closes: https://bugs.gentoo.org/777546 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'gui-libs/egl-wayland')
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild4
-rw-r--r--gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch7
2 files changed, 11 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
index 6d38529baad1..c853264cb3dd 100644
--- a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
@@ -22,6 +22,10 @@ DEPEND="
media-libs/libglvnd"
BDEPEND="dev-util/wayland-scanner"
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-werror.patch
+)
+
src_install() {
meson_src_install
diff --git a/gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch b/gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch
new file mode 100644
index 000000000000..ef392d9b5567
--- /dev/null
+++ b/gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch
@@ -0,0 +1,7 @@
+https://bugs.gentoo.org/777546
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -7,3 +7,2 @@
+ add_project_arguments('-Wall', language : 'c')
+-add_project_arguments('-Werror', language : 'c')
+ add_project_arguments('-fvisibility=hidden', language : 'c')