summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-12-11 03:23:42 +0100
committerMart Raudsepp <leio@gentoo.org>2020-12-19 12:58:17 +0200
commitd49b509524e4e7b1af29e14bdd98ba911fa921d6 (patch)
treea69960538ce5012e706febb0786271da2c906c03 /gui-libs/libhandy
parentsys-apps/fd: fix zsh completion in 8.2.1 (diff)
downloadgentoo-d49b509524e4e7b1af29e14bdd98ba911fa921d6.tar.gz
gentoo-d49b509524e4e7b1af29e14bdd98ba911fa921d6.tar.bz2
gentoo-d49b509524e4e7b1af29e14bdd98ba911fa921d6.zip
gui-libs/libhandy: bump to 1.0.2
Closes: https://github.com/gentoo/gentoo/pull/18604 Closes: https://bugs.gentoo.org/759439 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs/libhandy')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.0.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 67b522264f29..761fa6643579 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1 +1,2 @@
+DIST libhandy-1.0.2.tar.xz 388756 BLAKE2B c4995c5865378b133ba90125cd2c6c7500730be32b2426ccb323c878c22e556c0aad4eb0a5ab5f6ff936b3132a1717759af826e5bc0c9426b6f6972ac20f4f44 SHA512 411e016e1770ea83507a66e6e751f223304890cd193191c28cf751f8128dc5c98feb5342012596c10219e4da5a2445659395a0e7086d5c9990f7845b0406c685
DIST libhandy-v0.0.13.tar.bz2 394811 BLAKE2B 318c226f20b4d8032e984dbd47b4634e828b922dcbc244e4f3f35b94c38f27ed38427196d553809bb1d6bfa7c4830db5d27701e3595cac8a05b58a27ba4a2472 SHA512 a0918c55c9ac14af223a83db542e7dc815d97c844d1f0830a1bee4bdcdf248d00d049fa90fd2be96265535a68d56de5143ddd9264b5e997a902ac9558d5096f3
diff --git a/gui-libs/libhandy/libhandy-1.0.2.ebuild b/gui-libs/libhandy/libhandy-1.0.2.ebuild
new file mode 100644
index 000000000000..0348bd5b0b50
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Library with GTK widgets for mobile phones"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ -Dstatic=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}