summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-09-11 16:13:56 +0300
committerMart Raudsepp <leio@gentoo.org>2021-09-11 16:14:12 +0300
commit2491ef999d22a19b61a466c5d8df8542eb516435 (patch)
tree130988591a0c9c41494651872d28a2f639a81d47 /gui-libs
parentdev-python/debugpy: keyword ~riscv (diff)
downloadgentoo-2491ef999d22a19b61a466c5d8df8542eb516435.tar.gz
gentoo-2491ef999d22a19b61a466c5d8df8542eb516435.tar.bz2
gentoo-2491ef999d22a19b61a466c5d8df8542eb516435.zip
gui-libs/gtk: fix missing icon cache update with USE=examples
xdg.eclass was already used, but the phases were overridden without chaining up to them for the eclass to just take care of it with the code that automatically checks if any icons are installed. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtk/gtk-4.4.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/gui-libs/gtk/gtk-4.4.0.ebuild b/gui-libs/gtk/gtk-4.4.0.ebuild
index f0a65fdf2fe6..aaac1d34fc34 100644
--- a/gui-libs/gtk/gtk-4.4.0.ebuild
+++ b/gui-libs/gtk/gtk-4.4.0.ebuild
@@ -176,10 +176,12 @@ src_install() {
}
pkg_preinst() {
+ xdg_pkg_preinst
gnome2_schemas_savelist
}
pkg_postinst() {
+ xdg_pkg_postinst
gnome2_schemas_update
if ! has_version "app-text/evince"; then
@@ -190,5 +192,6 @@ pkg_postinst() {
}
pkg_postrm() {
+ xdg_pkg_postrm
gnome2_schemas_update
}