summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-12 22:47:41 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-12 22:47:41 -0500
commit275736286a01b5180cd35c32115563277135e77a (patch)
tree7f9c14dc2c42d974f0df91cf4a21a71c727babdf /gui-libs
parentgui-libs/wlroots: restore 0.6.0 per user request (diff)
downloadgentoo-275736286a01b5180cd35c32115563277135e77a.tar.gz
gentoo-275736286a01b5180cd35c32115563277135e77a.tar.bz2
gentoo-275736286a01b5180cd35c32115563277135e77a.zip
gui-libs/wlroots: drop old 0.8.0 after fixes for RDP and ffmpeg
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/wlroots-0.8.1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/gui-libs/wlroots/wlroots-0.8.1.ebuild b/gui-libs/wlroots/wlroots-0.8.1.ebuild
deleted file mode 100644
index fb0cf5f0576d..000000000000
--- a/gui-libs/wlroots/wlroots-0.8.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit fcaps meson
-
-DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
-HOMEPAGE="https://github.com/swaywm/wlroots"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/8"
-IUSE="elogind icccm systemd x11-backend X"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- >=dev-libs/libinput-1.9.0:0=
- >=dev-libs/wayland-1.17.0
- media-libs/mesa[egl,gles2,gbm]
- virtual/libudev
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pixman
- elogind? ( >=sys-auth/elogind-237 )
- icccm? ( x11-libs/xcb-util-wm )
- systemd? ( >=sys-apps/systemd-237 )
- x11-backend? ( x11-libs/libxcb:0= )
- X? (
- x11-base/xorg-server[wayland]
- x11-libs/libxcb:0=
- x11-libs/xcb-util-image
- )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.17
- virtual/pkgconfig
-"
-
-src_configure() {
- # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
- local emesonargs=(
- "-Dxcb-errors=disabled"
- -Dlibcap=$(usex filecaps enabled disabled)
- -Dxcb-icccm=$(usex icccm enabled disabled)
- -Dxwayland=$(usex X enabled disabled)
- -Dx11-backend=$(usex x11-backend enabled disabled)
- "-Dexamples=false"
- "-Dwerror=false"
- )
- if use systemd; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
- elif use elogind; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
- else
- emesonargs+=("-Dlogind=disabled")
- fi
-
- meson_src_configure
-}
-
-pkg_postinst() {
- elog "You must be in the input group to allow your compositor"
- elog "to access input devices via libinput."
-}