summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-09-15 22:59:57 +0300
committerMart Raudsepp <leio@gentoo.org>2021-09-15 22:59:57 +0300
commit499e98c6a7113b578bf043ee8e93f4d76157e127 (patch)
treebc6e56e9cb2fdfe991f6484498dc82a55687269f /gui-libs
parentnet-libs/libsoup:3.0: improve tests situation (diff)
downloadgentoo-499e98c6a7113b578bf043ee8e93f4d76157e127.tar.gz
gentoo-499e98c6a7113b578bf043ee8e93f4d76157e127.tar.bz2
gentoo-499e98c6a7113b578bf043ee8e93f4d76157e127.zip
gui-libs/libhandy: bump to 1.4.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.4.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 0c3fb1d65b20..e83537ad3a30 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1 +1,2 @@
DIST libhandy-1.2.3.tar.xz 491024 BLAKE2B b15e4b12135230ce6e588e005f55edada001abaa3fbdcf2f05b5e05f364beaa8983239f3a562b8600fc07edd6b6b7e834d42a06ec1ec626d7a43d6634ba93d0e SHA512 20ed6708bb517c81d9b8520c522555d7cdaf36f19dd29603a4f86d6d47ec2552af8874605b1866eb634d25afd0a2c18690cb1be6eafce81cac7857890388799e
+DIST libhandy-1.4.0.tar.xz 496476 BLAKE2B fca22f75348de5a485aa426f90201217e3f5b9bea664d9625b205990fa2c1a6e7ee32dfeec9a6695fcc9bfd841de1d2d310590ed6c59ec9835cb243f6bba54eb SHA512 a616430873cdd928d7875f776c5b98c66f1ab2f11422dffeed86844cec68cd212eb698413e38da0f0c38fc6c144372519ea1d03c8255fb4f7da9603c1713e6f8
diff --git a/gui-libs/libhandy/libhandy-1.4.0.ebuild b/gui-libs/libhandy/libhandy-1.4.0.ebuild
new file mode 100644
index 000000000000..8af23d0bf4e6
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}