summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-28 12:26:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-28 12:28:54 -0500
commit59a97bcaa50f1f967873aa5814fcfb9f4bec855e (patch)
treeea29cc9db2aef38ac61009af7dcf02295f17130e /gui-libs
parentdev-ros/image_cb_detector: fix build with boost 1.70 (diff)
downloadgentoo-59a97bcaa50f1f967873aa5814fcfb9f4bec855e.tar.gz
gentoo-59a97bcaa50f1f967873aa5814fcfb9f4bec855e.tar.bz2
gentoo-59a97bcaa50f1f967873aa5814fcfb9f4bec855e.zip
gui-libs/wlroots: 0.7.0 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.7.0.ebuild75
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild28
3 files changed, 77 insertions, 27 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 18e0eef41818..19d00f989cf9 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,3 +1,4 @@
DIST wlroots-0.4.1.tar.gz 480127 BLAKE2B f193860ef9e0852b053270bdaa44b491a8c65a76dc01c71690f7a006eac46e606cca95675e6dec4d65487d9b98bcabb7cd12578f028a9cb9c5cd648e47754df4 SHA512 bd8863c7f285579d81b9372f1335c10eb2d0fd7b46b7589e6b2acad53fa373f2e3b549d2c31876d87d66851af0415a12a011a05953ffe2384b718db6d95cba2e
DIST wlroots-0.5.0.tar.gz 481154 BLAKE2B 094c7c92191ea9c581debc90fa7b0117ed15328c11a098e53cec05b326e84c54481a69382ef9a592337ade370ffb55ea98b545794471808dee9f41ee9db8194f SHA512 4defecff91a6179d3a6b7d05c92c14b20c7fa69263a889869912e913a5d1e29f9fd4684f9816b03e2427a21c004d64236f35d8282e02e8d27d826442f1f8b3a7
DIST wlroots-0.6.0.tar.gz 497934 BLAKE2B a0b631831752e533f83ed62e402ef69b0994df050fd643cf2ef89556face4a822b3936bc758b70ab160eedda8ced16c0992dc209600914095784bba97bd26ee2 SHA512 c205d4303a381e11ef2f4db2faac1ddf9ad85c675824aae9cfe62d9f8bd313f1568d4810db1d006416783b50c8364198648a46d1ba453a0d8f659d6920618286
+DIST wlroots-0.7.0.tar.gz 446392 BLAKE2B ed69ae2e5484428222cd430d7c74935b0801044cacab804ffe3673c5ecf08104a5fbfbaa930c8ef4df3e43de1073910ba970028307a0a3c57483c5d502832292 SHA512 20e7e81bb945cc683c793f1258e83dbeea5e933faa066125f16a24aa7151000c620f9f47cad21540f8bea7d053d181cb89a2803c30fac1b1b9f3345065b9ba9c
diff --git a/gui-libs/wlroots/wlroots-0.7.0.ebuild b/gui-libs/wlroots/wlroots-0.7.0.ebuild
new file mode 100644
index 000000000000..540520bfd71d
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.7.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://github.com/swaywm/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind icccm systemd x11-backend X"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=dev-libs/libinput-1.9.0:0=
+ >=dev-libs/wayland-1.17.0
+ media-libs/mesa[egl,gles2,gbm]
+ virtual/libudev
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ elogind? ( >=sys-auth/elogind-237 )
+ icccm? ( x11-libs/xcb-util-wm )
+ systemd? ( >=sys-apps/systemd-237 )
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xorg-server[wayland]
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ -Dlibcap=$(usex filecaps enabled disabled)
+ -Dxcb-icccm=$(usex icccm enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dx11-backend=$(usex x11-backend enabled disabled)
+ "-Dexamples=false"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index db03b0f1e012..540520bfd71d 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind icccm rootston systemd x11-backend X"
+IUSE="elogind icccm systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -47,8 +47,6 @@ BDEPEND="
virtual/pkgconfig
"
-FILECAPS=( cap_sys_admin usr/bin/rootston )
-
src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
@@ -57,7 +55,6 @@ src_configure() {
-Dxcb-icccm=$(usex icccm enabled disabled)
-Dxwayland=$(usex X enabled disabled)
-Dx11-backend=$(usex x11-backend enabled disabled)
- $(meson_use rootston)
"-Dexamples=false"
"-Dwerror=false"
)
@@ -72,30 +69,7 @@ src_configure() {
meson_src_configure
}
-src_install() {
- if use rootston; then
- dobin "${BUILD_DIR}"/rootston/rootston
- newdoc rootston/rootston.ini.example rootston.ini
- fi
-
- meson_src_install
-}
-
pkg_postinst() {
elog "You must be in the input group to allow your compositor"
elog "to access input devices via libinput."
- if use rootston; then
- elog ""
- elog "You should copy (and decompress) the example configuration file"
- elog "from ${EROOT:-${ROOT}}/usr/share/doc/${PF}/rootston.ini"
- elog "to the working directory from where you launch rootston"
- elog "(or pass the '-C path-to-config' option to rootston)."
- if ! use systemd && ! use elogind; then
- elog ""
- elog "If you use ConsoleKit2, remember to launch rootston using:"
- elog "exec ck-launch-session rootston"
-
- fcaps_pkg_postinst
- fi
- fi
}