summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-22 18:02:35 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-22 21:59:56 -0700
commit6a1897c2fe888ac4de4a079d83658ed78fb4306e (patch)
treeace6a017ef0e98a48171fcad777cde00902c54a7 /gui-libs
parentwww-client/epiphany: Version bump to 42.2 (diff)
downloadgentoo-6a1897c2fe888ac4de4a079d83658ed78fb4306e.tar.gz
gentoo-6a1897c2fe888ac4de4a079d83658ed78fb4306e.tar.bz2
gentoo-6a1897c2fe888ac4de4a079d83658ed78fb4306e.zip
gui-libs/libhandy: Version bump to 1.6.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.6.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index cbde8dff3623..8ee262fbad40 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1,2 +1,3 @@
DIST libhandy-1.4.0.tar.xz 496476 BLAKE2B fca22f75348de5a485aa426f90201217e3f5b9bea664d9625b205990fa2c1a6e7ee32dfeec9a6695fcc9bfd841de1d2d310590ed6c59ec9835cb243f6bba54eb SHA512 a616430873cdd928d7875f776c5b98c66f1ab2f11422dffeed86844cec68cd212eb698413e38da0f0c38fc6c144372519ea1d03c8255fb4f7da9603c1713e6f8
DIST libhandy-1.6.1.tar.xz 1781604 BLAKE2B 87f33662397d569fbb58e04b3e61e282fdeede0098753dcdf5da885a13096007446eb2d404cf4231021fdb2cd76895faa37929dad651d54e57f5a623db6c7823 SHA512 1fddf72d7e6d97f12c879a512baeef80e32be4108640b2ff64c5b7dec68d8e2da8f9a2da3c1cb6cde8c2e672f4225e7db698f794641264e64ee9af3c68dbfbb3
+DIST libhandy-1.6.2.tar.xz 1783660 BLAKE2B 4819ee8917d324f795b5f983ba69a3a5e5e77addf45c83b63ab676407aadb335f1130d02f011a6fb479f7ab71fdac7030b6fadb42dea92ac2fa949ed6d240844 SHA512 482a848ec5b085e2c5dcc94a1a9be618de22f779dc8c8cc07945f6269d1061e96009700ee9e3ddf0ccac0ce2ac01ccb4da3a8d366f1b3b9ceecc282a46021a6d
diff --git a/gui-libs/libhandy/libhandy-1.6.2.ebuild b/gui-libs/libhandy/libhandy-1.6.2.ebuild
new file mode 100644
index 000000000000..c396cac2d01a
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}