summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-07 13:58:52 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-07 13:58:52 +0300
commitafed917c6d6fa55d02e75be70ccc7bdc62fb4ab6 (patch)
treee637812aba51f00a3e5ad8cf0f181d9b7bcbfbf8 /gui-libs
parentdev-cpp/glibmm: bump to 2.60.0 (diff)
downloadgentoo-afed917c6d6fa55d02e75be70ccc7bdc62fb4ab6.tar.gz
gentoo-afed917c6d6fa55d02e75be70ccc7bdc62fb4ab6.tar.bz2
gentoo-afed917c6d6fa55d02e75be70ccc7bdc62fb4ab6.zip
gui-libs/amtk: bump to 5.0.1
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/amtk/Manifest1
-rw-r--r--gui-libs/amtk/amtk-5.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gui-libs/amtk/Manifest b/gui-libs/amtk/Manifest
index 933a06b48e45..dfb4381d8a0a 100644
--- a/gui-libs/amtk/Manifest
+++ b/gui-libs/amtk/Manifest
@@ -1 +1,2 @@
DIST amtk-5.0.0.tar.xz 368524 BLAKE2B dae5e6c832fd0cb94a7afa0524a9ce863f72023a3648b01004c834f6a17fa285ccbe4d3ec87b54101b4fa644c3530ec6f4faebf3fa971ef201a4e6455a3fff54 SHA512 86433a7b314bfbdd00cd53a7223561645b0ebd40ec519f97b61e8df073b88c76425182ad71a49794090a51eddf68b81f4c7d88c4bf6a618311aa92908f5bea73
+DIST amtk-5.0.1.tar.xz 369192 BLAKE2B b31b60045ea122c814a719877ada69fba3753d33c30ad28b5d0c97cd358ae15d98c8f88c038b95aa64e8d5d9b23e3143b75d571f1dc32dc4178af49b0ecf8faf SHA512 21c581b9ea44bc6e9c13d5c9e6298b55a0f28b1943fab1943d2a8b53a9b82f8c29a983f73e5a4a66a16912645ff8c29023490380d6e6c3de157b9c35f56a4e00
diff --git a/gui-libs/amtk/amtk-5.0.1.ebuild b/gui-libs/amtk/amtk-5.0.1.ebuild
new file mode 100644
index 000000000000..d40019fdaa5e
--- /dev/null
+++ b/gui-libs/amtk/amtk-5.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Actions, Menus and Toolbars Kit for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/Amtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+ >=sys-devel/gettext-0.19.6
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gtk-doc \
+ --disable-installed-tests \
+ $(use_enable introspection) \
+ --disable-valgrind
+}