summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-01-27 14:24:15 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-01-27 14:24:47 -0600
commit7fdcb9fe3071e7e3189401b938acb73962c259b5 (patch)
treeda0e7890c2303d741e7f9240148b021af7dc1805 /gui-wm
parentsys-apps/systemd-utils: Stabilize 254.8 arm, #921962 (diff)
downloadgentoo-7fdcb9fe3071e7e3189401b938acb73962c259b5.tar.gz
gentoo-7fdcb9fe3071e7e3189401b938acb73962c259b5.tar.bz2
gentoo-7fdcb9fe3071e7e3189401b938acb73962c259b5.zip
gui-wm/sway: 1.9-rc1 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/Manifest1
-rw-r--r--gui-wm/sway/sway-1.9_rc1.ebuild108
-rw-r--r--gui-wm/sway/sway-9999.ebuild7
3 files changed, 113 insertions, 3 deletions
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index 472e57c3e226..d384efdee998 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1 +1,2 @@
DIST sway-1.8.1.tar.gz 5577483 BLAKE2B 0e21c3a113b6bbb4a535ef77e347304ead98a424b65c176299f3d86fd52c35abf88d4e88fff0a8ecdb48494e8275110c79ea35fafd2902653db03fd938ee0323 SHA512 1f9909cb0402a99926d0ff1cefb98c40930e61678067413b6f195b036e6018a4f85bb3a6649d8bb743c93f0476b103791617a94d7c8c11a2c021f40131b65563
+DIST sway-1.9_rc1.tar.gz 5580964 BLAKE2B 308551f0ef9144313b5a98aa54075cf4f188ff4033667ae0759e6f92740170fad8ccfa0867af8506c24deeb24148d014f11ea849917b9bd7150f167cf41d1ca1 SHA512 94dd3cf8550ec3a5f0c08dd1e3911287fc1ecf1bdf7ad54b375ad9c838b16e8a0d8b3c0be5a68337418366a7758820734a28f17c3ea659f7b431a513d052e860
diff --git a/gui-wm/sway/sway-1.9_rc1.ebuild b/gui-wm/sway/sway-1.9_rc1.ebuild
new file mode 100644
index 000000000000..a3202673f8d0
--- /dev/null
+++ b/gui-wm/sway/sway-1.9_rc1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ MY_PV=${PV/_rc/-rc}
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man +swaybar +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.21.0:0=
+ virtual/libudev
+ sys-auth/seatd:=
+ dev-libs/libpcre2
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ >=x11-libs/libxkbcommon-1.5.0:0=
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ tray? ( || (
+ sys-apps/systemd
+ sys-auth/elogind
+ sys-libs/basu
+ ) )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
+ X? (
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-wm
+ )
+"
+# x11-libs/xcb-util-wm needed for xcb-iccm
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~gui-libs/wlroots-9999:=[X?]"
+else
+ DEPEND+="
+ >=gui-libs/wlroots-0.17:=[X?]
+ <gui-libs/wlroots-0.18:=[X?]
+ "
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-build/meson-0.60.0
+ virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+REQUIRED_USE="tray? ( swaybar )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ insinto /usr/share/xdg-desktop-portal
+ doins "${FILESDIR}/sway-portals.conf"
+}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with sway:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index cc93fa47b729..a3202673f8d0 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -25,11 +25,12 @@ IUSE="+man +swaybar +swaynag tray wallpapers X"
DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.21.0:0=
+ virtual/libudev
sys-auth/seatd:=
dev-libs/libpcre2
>=dev-libs/wayland-1.20.0
x11-libs/cairo
- x11-libs/libxkbcommon
+ >=x11-libs/libxkbcommon-1.5.0:0=
x11-libs/pango
x11-libs/pixman
media-libs/mesa[gles2,libglvnd(+)]
@@ -50,8 +51,8 @@ if [[ ${PV} == 9999 ]]; then
DEPEND+="~gui-libs/wlroots-9999:=[X?]"
else
DEPEND+="
- >=gui-libs/wlroots-0.16:=[X?]
- <gui-libs/wlroots-0.17:=[X?]
+ >=gui-libs/wlroots-0.17:=[X?]
+ <gui-libs/wlroots-0.18:=[X?]
"
fi
RDEPEND="