summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-06 16:02:20 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-06 20:12:14 -0400
commitac6d97bb0b5d1f0cad586def0afe79733b540e3d (patch)
tree03fc58e2fee86e6fa2c2425f4b1a84f644940eb5 /gui-wm
parentgui-libs/wf-config: remove debug symbols (diff)
downloadgentoo-ac6d97bb0b5d1f0cad586def0afe79733b540e3d.tar.gz
gentoo-ac6d97bb0b5d1f0cad586def0afe79733b540e3d.tar.bz2
gentoo-ac6d97bb0b5d1f0cad586def0afe79733b540e3d.zip
gui-wm/wayfire: remove debug symbols
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/wayfire/metadata.xml3
-rw-r--r--gui-wm/wayfire/wayfire-0.4.0-r1.ebuild (renamed from gui-wm/wayfire/wayfire-0.4.0.ebuild)15
-rw-r--r--gui-wm/wayfire/wayfire-9999.ebuild15
3 files changed, 11 insertions, 22 deletions
diff --git a/gui-wm/wayfire/metadata.xml b/gui-wm/wayfire/metadata.xml
index c61941f4b35f..5765c019ed73 100644
--- a/gui-wm/wayfire/metadata.xml
+++ b/gui-wm/wayfire/metadata.xml
@@ -15,9 +15,8 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="gles2">use libglvnd to do animations more efficiently</flag>
+ <flag name="gles">use libglvnd to do animations more efficiently</flag>
<flag name='system-wfconfig'>use the system-wide wf-config, else build it as a submodule. DO NOT DISABLE UNLESS YOU KNOW WHAT YOU ARE DOING.</flag>
<flag name='system-wlroots'>use the system wide wlroots, else build it as a submodule. DO NOT DISABLE UNLESS YOU KNOW WHAT YOU ARE DOING.</flag>
- <flag name='debug'>add debugging symbols for error reporting. DISABLE ALL SYSTEM USE FLAGS BEFORE REPORTING BUGS.</flag>
</use>
</pkgmetadata>
diff --git a/gui-wm/wayfire/wayfire-0.4.0.ebuild b/gui-wm/wayfire/wayfire-0.4.0-r1.ebuild
index 960c79380369..9de00654b844 100644
--- a/gui-wm/wayfire/wayfire-0.4.0.ebuild
+++ b/gui-wm/wayfire/wayfire-0.4.0-r1.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="+gles2 +system-wfconfig +system-wlroots elogind systemd debug"
+IUSE="+gles +system-wfconfig +system-wlroots elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -35,10 +35,10 @@ DEPEND="
x11-libs/cairo:=[X,svg]
x11-libs/libxkbcommon:=[X]
x11-libs/pixman
- gles2? ( media-libs/libglvnd[X] )
- system-wfconfig? ( ~gui-libs/wf-config-${PV}[debug=] )
+ gles? ( media-libs/libglvnd[X] )
+ system-wfconfig? ( ~gui-libs/wf-config-${PV} )
!system-wfconfig? ( !gui-libs/wf-config )
- system-wlroots? ( ~gui-libs/wlroots-0.10.0[elogind=,systemd=,X] )
+ system-wlroots? ( ~gui-libs/wlroots-0.10.1[elogind=,systemd=,X] )
!system-wlroots? ( !gui-libs/wlroots )
"
@@ -59,13 +59,8 @@ src_configure() {
local emesonargs=(
$(meson_feature system-wfconfig use_system_wfconfig)
$(meson_feature system-wlroots use_system_wlroots)
- $(meson_use gles2 enable_gles32)
+ $(meson_use gles enable_gles32)
)
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
meson_src_configure
}
diff --git a/gui-wm/wayfire/wayfire-9999.ebuild b/gui-wm/wayfire/wayfire-9999.ebuild
index 2ca45c4a7e86..3a3d136e62b0 100644
--- a/gui-wm/wayfire/wayfire-9999.ebuild
+++ b/gui-wm/wayfire/wayfire-9999.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="+gles2 +system-wfconfig +system-wlroots elogind systemd debug"
+IUSE="+gles +system-wfconfig +system-wlroots elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -35,10 +35,10 @@ DEPEND="
x11-libs/cairo:=[X,svg]
x11-libs/libxkbcommon:=[X]
x11-libs/pixman
- gles2? ( media-libs/libglvnd[X] )
- system-wfconfig? ( ~gui-libs/wf-config-${PV}[debug=] )
+ gles? ( media-libs/libglvnd[X] )
+ system-wfconfig? ( ~gui-libs/wf-config-${PV} )
!system-wfconfig? ( !gui-libs/wf-config )
- system-wlroots? ( >=gui-libs/wlroots-0.10.1[elogind=,systemd=,X] )
+ system-wlroots? ( ~gui-libs/wlroots-9999[elogind=,systemd=,X] )
!system-wlroots? ( !gui-libs/wlroots )
"
@@ -59,13 +59,8 @@ src_configure() {
local emesonargs=(
$(meson_feature system-wfconfig use_system_wfconfig)
$(meson_feature system-wlroots use_system_wlroots)
- $(meson_use gles2 enable_gles32)
+ $(meson_use gles enable_gles32)
)
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
meson_src_configure
}