summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-24 21:06:37 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-24 21:06:37 +0200
commitcc8a661a762039423faff1c4ca01e182616ca6ee (patch)
tree34406da7a8d82f3478c6713c6667af162ea640e7 /gui-wm
parentgui-wm/sway: add 1.9 (diff)
downloadgentoo-cc8a661a762039423faff1c4ca01e182616ca6ee.tar.gz
gentoo-cc8a661a762039423faff1c4ca01e182616ca6ee.tar.bz2
gentoo-cc8a661a762039423faff1c4ca01e182616ca6ee.zip
gui-wm/sway: sync live
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/sway-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index a3202673f8d0..905df0af237e 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson optfeature
+inherit fcaps meson optfeature
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
@@ -21,6 +21,7 @@ fi
LICENSE="MIT"
SLOT="0"
IUSE="+man +swaybar +swaynag tray wallpapers X"
+REQUIRED_USE="tray? ( swaybar )"
DEPEND="
>=dev-libs/json-c-0.13:0=
@@ -69,7 +70,10 @@ if [[ ${PV} == 9999 ]]; then
else
BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
fi
-REQUIRED_USE="tray? ( swaybar )"
+
+FILECAPS=(
+ cap_sys_nice usr/bin/${PN} # bug 919298
+)
src_configure() {
local emesonargs=(
@@ -95,6 +99,8 @@ src_install() {
}
pkg_postinst() {
+ fcaps_pkg_postinst
+
optfeature_header "There are several packages that may be useful with sway:"
optfeature "wallpaper utility" gui-apps/swaybg
optfeature "idle management utility" gui-apps/swayidle
@@ -102,7 +108,7 @@ pkg_postinst() {
optfeature "lightweight notification daemon" gui-apps/mako
echo
einfo "For a list of additional addons and tools usable with sway please"
- einfo "visit the offical wiki at:"
+ einfo "visit the official wiki at:"
einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
einfo "Please note that some of them might not (yet) available on gentoo"
}