summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-22 16:11:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-22 16:20:09 -0600
commitcf252c7cc2179483ae82bfb0cdaf5d32a5d888be (patch)
tree188312cfad2c07d27fe5fe7c08b766978e22953d /gui-wm
parentgui-libs/wlroots: cleanup (diff)
downloadgentoo-cf252c7cc2179483ae82bfb0cdaf5d32a5d888be.tar.gz
gentoo-cf252c7cc2179483ae82bfb0cdaf5d32a5d888be.tar.bz2
gentoo-cf252c7cc2179483ae82bfb0cdaf5d32a5d888be.zip
gui-wm/sway: 1.4 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/Manifest1
-rw-r--r--gui-wm/sway/sway-1.4.ebuild116
-rw-r--r--gui-wm/sway/sway-9999.ebuild6
3 files changed, 121 insertions, 2 deletions
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index e884084d112f..b79052223131 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1,2 +1,3 @@
DIST sway-1.1.1.tar.gz 5480615 BLAKE2B 2cc55535a030d5d057c332a8b2647f394ec8f08a3a5aebe48e0bd21da718eac23bdbcc5a2ce26624efb9360518e5f14eaafe406e1c7d9b3eb81621bab7b6c39c SHA512 2585446ca0936df41c7959b6b48487b25c86f1a8a3bedcd146aab023a873a416ce750698e3cabcd9cb861e35bbd7e280574ff477152906669af9b17d3e54028e
DIST sway-1.2.tar.gz 5493376 BLAKE2B f059ec7c3db7ff048129c9d701e8730b04f01670dc3b1be826ef3d609f2881ddf1e3bfd82c39bebf5e7e99127f7250239b2af76292f60cfa208fc465f14cd779 SHA512 b43f625d35145a3377e64ea942f8b005946bb0925f08deace2da73ab504038b29331df9943296c97141e2283cd9b55e6cb3bca18c5c3999ecbd461325e36165b
+DIST sway-1.4.tar.gz 5514489 BLAKE2B 31eb1aee32079e643cc7a0263a097000c089e36916ea2a681e1ec696f8329e7ecfe3c8a981ec3b6d4e3dd99c8e263b2c208dbe602308d6bdaf4cdabbb3c10971 SHA512 3b280bdfdbdae8fb9b4f555bc630c64e7c1d09f7b2c783b99413863a6b620d50cd2b6d10d63e11fdfb9c678fce9a403228ac52fa69fb52561ffbd06790505a71
diff --git a/gui-wm/sway/sway-1.4.ebuild b/gui-wm/sway/sway-1.4.ebuild
new file mode 100644
index 000000000000..abaa40139b8f
--- /dev/null
+++ b/gui-wm/sway/sway-1.4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils meson
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ MY_PV=${PV/_rc/-rc}
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )
+ tray? ( || ( elogind systemd ) )"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.6.0:0=
+ dev-libs/libpcre
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2]
+ elogind? ( >=sys-auth/elogind-239 )
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( gui-apps/swaybg )
+ swayidle? ( gui-apps/swayidle )
+ swaylock? ( gui-apps/swaylock )
+ systemd? ( >=sys-apps/systemd-239 )
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
+else
+ DEPEND+="
+ >=gui-libs/wlroots-0.10.0:=[elogind=,systemd=,X=]
+ <gui-libs/wlroots-0.11.0:=[elogind=,systemd=,X=]
+ "
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_prepare() {
+ default
+
+ use swaybar || sed -e "s/subdir('swaybar')//g" -e "/sway-bar.[0-9].scd/d" \
+ -e "/completions\/[a-z]\+\/_\?swaybar/d" -i meson.build || die
+ use swaymsg || sed -e "s/subdir('swaymsg')//g" -e "/swaymsg.[0-9].scd/d" \
+ -e "/completions\/[a-z]\+\/_\?swaymsg/d" -i meson.build || die
+ use swaynag || sed -e "s/subdir('swaynag')//g" -e "/swaynag.[0-9].scd/d" \
+ -e "/completions\/[a-z]\+\/_\?swaynag/d" -i meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dtray=$(usex tray enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
+ $(meson_use wallpapers default-wallpaper)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+
+ if use swaybar; then
+ emesonargs+=("-Dgdk-pixbuf=enabled")
+ else
+ emesonargs+=("-Dgdk-pixbuf=disabled")
+ fi
+
+ meson_src_configure
+}
+
+pkg_preinst() {
+ if ! use systemd && ! use elogind; then
+ fowners root:0 /usr/bin/sway
+ fperms 4511 /usr/bin/sway
+ fi
+}
+
+pkg_postinst() {
+ if ! use systemd && ! use elogind; then
+ elog ""
+ elog "If you use ConsoleKit2, remember to launch sway using:"
+ elog "exec ck-launch-session sway"
+ elog ""
+ elog "If your system does not set the XDG_RUNTIME_DIR environment"
+ elog "variable, you must set it manually to run Sway. See wiki"
+ elog "for details: https://wiki.gentoo.org/wiki/Sway"
+ fi
+}
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index f8f9789c4d08..abaa40139b8f 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -45,8 +45,10 @@ DEPEND="
if [[ ${PV} == 9999 ]]; then
DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
else
- DEPEND+=">=gui-libs/wlroots-0.9.0:=[elogind=,systemd=,X=]"
- DEPEND+="<gui-libs/wlroots-0.10.0:=[elogind=,systemd=,X=]"
+ DEPEND+="
+ >=gui-libs/wlroots-0.10.0:=[elogind=,systemd=,X=]
+ <gui-libs/wlroots-0.11.0:=[elogind=,systemd=,X=]
+ "
fi
RDEPEND="
x11-misc/xkeyboard-config