summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:13:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:46:08 +0200
commit2de492f66f593f97c84056a21259aaa5653681dd (patch)
treefe20d10d8a88b87b3b6ef55c8ac06f5b3621c0f0 /kde-apps/akonadi-contacts
parentkde5.eclass: Disable kdoctools_install(po) if KDE_HANDBOOK=forceoptional (diff)
downloadgentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.gz
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.bz2
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.zip
kde-apps: Add KDE Applications 17.04.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps/akonadi-contacts')
-rw-r--r--kde-apps/akonadi-contacts/Manifest1
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-17.04.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/Manifest b/kde-apps/akonadi-contacts/Manifest
index 7dcf420610a4..89f5b8e4a4de 100644
--- a/kde-apps/akonadi-contacts/Manifest
+++ b/kde-apps/akonadi-contacts/Manifest
@@ -1 +1,2 @@
DIST akonadi-contacts-17.04.0.tar.xz 348192 SHA256 67fc0795c10f43c2c6a27ad5619ab044f3c527789a84ce8fbf6ce9652b06dc05 SHA512 8eed24cba8b85a9a05738a5fe5820d7fb4b785fbf12d58fb6830ba272a2b84908f7f65c48888d881f9080a5a502ece90ff21fdf27df8596967153b823025d206 WHIRLPOOL e8b3abeb17598cc4f1ac7361f3322df854cd3662cb91a757bacdc60792b02067d8e4c79b96121432c4fa414e3136afdd9cd6d516bbcd659ff79abf2b928288a4
+DIST akonadi-contacts-17.04.1.tar.xz 348024 SHA256 5397d601a9a02c9935aea5864c5d62aac285193dd170fcc5882fa2c155896329 SHA512 5c92667ae0ff34aacd72698cb6229c4d89ba384d913de5b9bc5f777530362ce7ee3d32d4c2eb47f77159c7996ba6c23b2603a8c29a5578b75f103f471cae0957 WHIRLPOOL 85368a59e7940639d17bcd81562143a4c45e46b79511206fbbba58f6ee3b118b54c4a2a3025565ff7bfed5808ae19fdcd444e5c220c3aac5fbe8220e78ed83a0
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-17.04.1.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-17.04.1.ebuild
new file mode 100644
index 000000000000..7030cb9808b1
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-17.04.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE="prison"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/grantlee-5.1.0:5
+ prison? ( $(add_frameworks_dep prison) )
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package prison KF5Prison)
+ )
+
+ kde5_src_configure
+}