summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-09 20:09:53 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-09 20:26:05 +0100
commit40cce1797befe332a79f52bba80e3d144297ceff (patch)
treea466705e4322739fd5dc6f2501eb401b5fe02385 /kde-apps/akonadi-contacts
parentdev-db/percona-server: Security cleanup (bug #612150) (diff)
downloadgentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.gz
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.bz2
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.zip
kde-apps: Version bump KDE Applications 16.12.3
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'kde-apps/akonadi-contacts')
-rw-r--r--kde-apps/akonadi-contacts/Manifest1
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-16.12.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/Manifest b/kde-apps/akonadi-contacts/Manifest
index 57561f5fa8ba..d03e4d891c3c 100644
--- a/kde-apps/akonadi-contacts/Manifest
+++ b/kde-apps/akonadi-contacts/Manifest
@@ -1 +1,2 @@
DIST akonadi-contacts-16.12.2.tar.xz 149284 SHA256 f7dd0c0495257b9670534dab0e5174c85b11e38b889aec284e18f6a93e0eadc7 SHA512 0345aa728b6718025fb0ecac73a2bf8f21936c185c041e6b542e08d9fb5393880c938d4d434e3fda39d25baaed4efdee020464b073a36a3fa766ebd471b8fc5b WHIRLPOOL d5d2ab167d9176c048df0668b1d8004b5881da918b2cb330a90e8073a56f0f31d85fd77cd86ef343d67f039aac0156aa7e4d6fb074ca124b91187b59b8ff6bf1
+DIST akonadi-contacts-16.12.3.tar.xz 149268 SHA256 54345dc2dfbafce76533a2b461fe11a7a266406516d6cc359202fc5c3e790588 SHA512 752674655df328a2e083fc475655e38e9a4fee7a0a78c44c08d62628a39a831c5be3cd3c63971959dc3000947bd4eafc0fd73a497682b3544c611a2c2f56948f WHIRLPOOL 70a9aac22d911192270d5582eb2265b8c04ee9a6c308859efe6c3ce3e6827d58508fa75fe8ed96a718010ed9ca4981cfe64252985120a59685e20c119218cc5b
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-16.12.3.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-16.12.3.ebuild
new file mode 100644
index 000000000000..b31d26b669e5
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-16.12.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE="prison"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/grantlee-5.1.0:5
+ prison? ( $(add_frameworks_dep prison) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package prison KF5Prison)
+ )
+
+ kde5_src_configure
+}