summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-28 21:02:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-28 23:28:23 +0200
commit1d57a7d5e8a0054ada73fe713f2864aeef6b2c7c (patch)
tree9962df61243cb1f1c5192639cd9e7fb9518fcb7f /kde-apps/ark
parentkde-apps/ark: Fix CVE-2020-24654 (diff)
downloadgentoo-1d57a7d5e8a0054ada73fe713f2864aeef6b2c7c.tar.gz
gentoo-1d57a7d5e8a0054ada73fe713f2864aeef6b2c7c.tar.bz2
gentoo-1d57a7d5e8a0054ada73fe713f2864aeef6b2c7c.zip
kde-apps/ark: Try unrestrict tests again, but disable failing
Sync with kde overlay 20.08 stable branch. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/ark-20.08.1.ebuild45
1 files changed, 18 insertions, 27 deletions
diff --git a/kde-apps/ark/ark-20.08.1.ebuild b/kde-apps/ark/ark-20.08.1.ebuild
index d96ecd65de21..d683f2a50092 100644
--- a/kde-apps/ark/ark-20.08.1.ebuild
+++ b/kde-apps/ark/ark-20.08.1.ebuild
@@ -8,10 +8,10 @@ ECM_TEST="optional"
KFMIN=5.72.0
QTMIN=5.14.2
VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
+inherit ecm kde.org optfeature
-DESCRIPTION="KDE Archiving tool"
-HOMEPAGE="https://kde.org/applications/utilities/org.kde.ark
+DESCRIPTION="File archiver by KDE"
+HOMEPAGE="https://kde.org/applications/en/ark
https://utils.kde.org/projects/ark/"
LICENSE="GPL-2" # TODO: CHECK
@@ -50,9 +50,6 @@ DEPEND="${RDEPEND}
>=dev-qt/qtconcurrent-${QTMIN}:5
"
-# bug #560548, last checked with 16.04.1
-RESTRICT+=" test"
-
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package zip LibZip)
@@ -61,28 +58,22 @@ src_configure() {
ecm_src_configure
}
-pkg_postinst() {
- ecm_pkg_postinst
-
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- if ! has_version app-arch/rar; then
- elog "For creating/extracting rar archives, installing app-arch/rar is required."
- if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
- elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
- fi
- fi
-
- has_version app-arch/p7zip || \
- elog "For handling 7-Zip archives, install app-arch/p7zip."
+src_test() {
+ local myctestargs=(
+ -E "(plugins-clirartest)"
+ )
- has_version app-arch/lrzip || \
- elog "For handling lrz archives, install app-arch/lrzip."
+ ecm_src_test
+}
- if ! has_version kde-misc/markdownpart:${SLOT} ||
- ! has_version kde-misc/kmarkdownwebview:${SLOT} ; then
- elog "For markdown support in text previews, install one of:"
- elog " kde-misc/markdownpart:${SLOT}"
- elog " kde-misc/kmarkdownwebview:${SLOT}"
- fi
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "rar archive creation/extraction" app-arch/rar
+ optfeature "rar archive extraction only" app-arch/unar app-arch/unrar
+ optfeature "7-Zip archive support" app-arch/p7zip
+ optfeature "lrz archive support" app-arch/lrzip
+ optfeature "markdown support in text previews" kde-misc/markdownpart:${SLOT} kde-misc/kmarkdownwebview:${SLOT}
fi
+ ecm_pkg_postinst
}