summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:28:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commit8e9254c5dac34b290d80baa283964bf5802d6630 (patch)
treee74c0d8d4491416d64de7802e3937452a509b1f1 /kde-apps/cantor
parentkde-frameworks: Add KDE Frameworks 5.43.0 (diff)
downloadgentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.gz
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.bz2
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.zip
kde-apps: Add KDE Applications 17.12.2
Bug: https://bugs.gentoo.org/642854 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-17.12.2.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index 940af9346140..6ed49fbe9e28 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,2 +1,3 @@
DIST cantor-17.08.3.tar.xz 1062400 BLAKE2B c9ee9ca23679566c7e8b1895a6ef5a332d486f8abea75242529cd5a5f99f506cd1b3dfef5591a6275272a5a0b8441ff9ef1cf8621c236a7357c5391d187e60be SHA512 92d40921b4121e7053381f071eaf08ba2a5bfdd42272ff749db726aa300878561b8079118a0ea61173269abb04fa1cbfeb8dba27da8701ecd2b17876c64a108b
DIST cantor-17.12.1.tar.xz 1064476 BLAKE2B 64eb91b1f0f033c5d6d33c21c9077cac1eb3ccfe33f25047dd18af8fec029cf1b5b26c5f68908eb3d12741ea48857639bb38db97748e48a6880993d37568711a SHA512 d15d9699e05a01fe5f376942dd39fdc9f6e8189819d44b11dbadb7ac43638766a233a361d107aa572e16df598eec4e220bfb9740d741d60a10ea7b00bb6fe095
+DIST cantor-17.12.2.tar.xz 1064220 BLAKE2B 45315ff528d7e032f1dc49f13be53f81f819d7cac8d85e6f8d1d32ebd94207e0885ba951412ad3f1602eaac59b5b6ef227b124afbb1caa6674e6204acb874d62 SHA512 3ee1d8eb845b2637a83545e28566d55d361204d21a698acc24017a2d639387b6804508fad8c533975dff80c4a4779d282333f6321447fd906fe2ff733be5b6e0
diff --git a/kde-apps/cantor/cantor-17.12.2.ebuild b/kde-apps/cantor/cantor-17.12.2.ebuild
new file mode 100644
index 000000000000..cd2bf41394b4
--- /dev/null
+++ b/kde-apps/cantor/cantor-17.12.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+PYTHON_COMPAT=( python2_7 )
+# FIXME: PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor/"
+KEYWORDS="~amd64 ~x86"
+IUSE="+analitza julia lua postscript python qalculate R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ analitza? ( $(add_kdeapps_dep analitza) )
+ julia? ( dev-lang/julia )
+ lua? ( dev-lang/luajit:2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate:=
+ )
+ postscript? ( app-text/libspectre )
+ python? ( ${PYTHON_DEPS} )
+ R? ( dev-lang/R )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT+=" test"
+
+pkg_pretend() {
+ kde5_pkg_pretend
+
+ if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
+ ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
+ einfo "You have decided to build ${PN} with no backend."
+ einfo "To have this application functional, please enable one of the backends via USE flag:"
+ einfo " analitza, lua, python, qalculate"
+ einfo "Alternatively, install one of these:"
+ einfo " # emerge sci-mathematics/maxima (bug #619534)"
+ einfo " # emerge sci-mathematics/octave"
+ einfo "Experimental available USE flags:"
+ einfo " julia (not stable, bug #613576), R (bug #619534)"
+ einfo
+ fi
+
+ if ! has_version virtual/latex-base; then
+ einfo "For LaTeX support:"
+ einfo " # emerge virtual/latex-base"
+ fi
+}
+
+pkg_setup() {
+ use python && python_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
+ sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
+ -i src/backends/CMakeLists.txt || die
+}
+
+src_configure() {
+ use julia && addpredict /proc/self/mem # bug 602894
+
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package analitza Analitza5)
+ $(cmake-utils_use_find_package julia Julia)
+ $(cmake-utils_use_find_package lua LuaJIT)
+ $(cmake-utils_use_find_package postscript LibSpectre)
+ $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ $(cmake-utils_use_find_package R R)
+ )
+ kde5_src_configure
+}