summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/dolphin-plugins-bazaar
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-bazaar')
-rw-r--r--kde-apps/dolphin-plugins-bazaar/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-bazaar/Manifest b/kde-apps/dolphin-plugins-bazaar/Manifest
index 81c358f7a48b..3639f0d8f72b 100644
--- a/kde-apps/dolphin-plugins-bazaar/Manifest
+++ b/kde-apps/dolphin-plugins-bazaar/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-18.12.0.tar.xz 191844 BLAKE2B cf4c59909f961d2c295e6a15e963c409302f9ae52c001c284015977c88ed4d6fa71b47d0402bc7049834c702d94169a543e7552f6517882578dc9a0d490bfc6e SHA512 237fb4204267894903708ced1fed771871591606c12d3a25fb1452526fc71146f53f1e26c97954897eab97f08bfacc277dd189082c53aa867829a61e3b098348
+DIST dolphin-plugins-18.12.1.tar.xz 191968 BLAKE2B 22db98fa22fc3c063c1f7729418957af24517de18dfb6c3c78b416e9d3c9cb99dc49b00f1bf3ede09c48dcded8ce3bf9072cbb062cca7078837f4b5898a69abd SHA512 83fb10c3753648a03817df8afce53d22d0cf98b657f00782b1db47067f4a5731de5946ab5b83bac132ecaf54770645563ea379afe614dc8500007ce0ace0d65b
diff --git a/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.1.ebuild b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.1.ebuild
new file mode 100644
index 000000000000..d90ff3f81dea
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="bazaar"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Bazaar integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/bzr
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}