summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/dolphin-plugins-dropbox
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-19.04.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index e733904af190..228cad70d876 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-18.12.3.tar.xz 191992 BLAKE2B 82dc3e03008949bc0af0c5938365b2d4dadbe8cafc0e7969e8c3a05804a53bfe6feb5e62e2f90f98940150709834472ff5b642681c7a6386b6362df8e4e75726 SHA512 a7d022652d80e832209c507b293c2701a8a3537d2b494e72c1e09dda9159751be8287991441869c0ce4cb8346c8c11fa537e94e06effb8e02d4f9f1fedaf9bf7
DIST dolphin-plugins-19.04.2.tar.xz 192500 BLAKE2B 3dbd10e7ed153b16defe11865aec676be064fff4ebf96f8217170a6d197fe83c0dbb884ef8f977f83a52dbc62282bc37e449f1f129c983d30cea0554f7724682 SHA512 2e1be6581a4d484daa0f1361df1fd6599423daab11522bc6665dcd682bd8b6da5aa732f28cdabc4fae76bf94216124c3c97ed3d3530a456643da5338fca4b815
+DIST dolphin-plugins-19.04.3.tar.xz 191524 BLAKE2B 8869c9e5c4de20b64ad426db82ce2249821f2bf6ceec958f55b385b16c3c85af7b4e908a37f422e79454ee1ba4f604e1ed9a4ef7ba7ff431dffb32d7443c55e3 SHA512 5a89daee3a4366905bd5c884460b62b9faf75989f8bb9b108f019c4359c5ea6406efcaf896a3504870819467130cd76e31a92cf9d697a5306293b5efd701e4c3
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-19.04.3.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-19.04.3.ebuild
new file mode 100644
index 000000000000..a9451d744149
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-19.04.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="dropbox"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}