summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 12:40:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 16:29:37 +0200
commit77996f0bd46af757187d387e251f25fdf21a33f8 (patch)
tree18c9cc45de05d82b4e08b5966b62d51dc802872e /kde-apps/dolphin-plugins-git
parentwww-client/opera-beta: Old (diff)
downloadgentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.gz
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.bz2
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.zip
kde-apps: Add KDE Applications 19.04.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.04.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 8b0d0a0a3bbc..3eaaba321665 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-18.12.3.tar.xz 191992 BLAKE2B 82dc3e03008949bc0af0c5938365b2d4dadbe8cafc0e7969e8c3a05804a53bfe6feb5e62e2f90f98940150709834472ff5b642681c7a6386b6362df8e4e75726 SHA512 a7d022652d80e832209c507b293c2701a8a3537d2b494e72c1e09dda9159751be8287991441869c0ce4cb8346c8c11fa537e94e06effb8e02d4f9f1fedaf9bf7
+DIST dolphin-plugins-19.04.0.tar.xz 192060 BLAKE2B 9024f60355f18e4961b5df543789f7c92501ff4162bea235760f47c5870e018fa42f092e4b3896ae470406f3b37b0171f814a48d246f085f377f215b8964f0ad SHA512 a9b8104f6472053f5e7b95a53238a2673d819a025b878a998c17c017683a1d61adbdd0abef6a40a4f3257735e2c16ca5a7550e95fe0bfa99ae470f3a4fe30ed5
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.04.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.04.0.ebuild
new file mode 100644
index 000000000000..1c11cb316cb2
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.04.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="git"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Git integration"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}