summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-15 15:08:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-15 15:09:32 +0200
commit54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9 (patch)
treeb1b36d8867b77df28e956c3f88378ef5518961f9 /kde-apps/dolphin
parentkde-misc/kio-gdrive: Pin kde-apps/libkgapi version to <19.04.50 (diff)
downloadgentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.tar.gz
gentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.tar.bz2
gentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.zip
kde-apps: Add KDE Applications 19.08.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-19.08.0.ebuild90
-rw-r--r--kde-apps/dolphin/metadata.xml7
3 files changed, 95 insertions, 3 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 91863d9b0bb2..d4f8210ca1ca 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1 +1,2 @@
DIST dolphin-19.04.3.tar.xz 5128016 BLAKE2B 9cf2b075cdbe87002589aa99c31036ad9648a6f70cd248698ff38b0a983a2b59100b52cd6645396d613294dac70a33bca1a52ea225630c15339e0f8f471ac0c1 SHA512 b0838f2ec1e1a22912a1178a262d7cc680dba5f11828bb0dac6bf59bf4c1a2affab912994d4f43adfe299bacd337848d11333996cfdfa54940f8604667e97e3a
+DIST dolphin-19.08.0.tar.xz 5253048 BLAKE2B 702cb5763ee39342381653d583aeebabb4efc7ad13a150bee650d6fb0aee96c8c9b0140b55236ca1613db7455f768f6d2f4ab0d51c2a21134f19790fe04b28bd SHA512 39afe693238b375f81a270d8b28a58c543aaab2a11e59d1c29f0daacbdaf1c43c271aae14104ba574349db2de690cef577d2143487248c86607ec247bc653824
diff --git a/kde-apps/dolphin/dolphin-19.08.0.ebuild b/kde-apps/dolphin/dolphin-19.08.0.ebuild
new file mode 100644
index 000000000000..158e8af0b6d2
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-19.08.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="activities semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ activities? ( $(add_frameworks_dep kactivities) )
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package activities KF5Activities)
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "kde-apps/ark:${SLOT}" || \
+ elog "For compress/extract and other actions install kde-apps/ark:${SLOT}"
+
+ has_version "kde-apps/kleopatra:${SLOT}" || \
+ elog "For crypto actions install kde-apps/kleopatra:${SLOT}"
+
+ has_version "kde-apps/ffmpegthumbs:${SLOT}" || \
+ elog "For video file thumbnails install kde-apps/ffmpegthumbs:${SLOT}"
+
+ has_version "kde-apps/thumbnailers:${SLOT}" || \
+ elog "For graphics file thumbnails install kde-apps/thumbnailers:${SLOT}"
+
+ has_version "kde-frameworks/purpose:${SLOT}" || \
+ elog "For 'Share' context menu actions install kde-frameworks/purpose:${SLOT}"
+ fi
+}
diff --git a/kde-apps/dolphin/metadata.xml b/kde-apps/dolphin/metadata.xml
index 6038ccc85636..32739ea6f617 100644
--- a/kde-apps/dolphin/metadata.xml
+++ b/kde-apps/dolphin/metadata.xml
@@ -1,11 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <use>
- <flag name="thumbnail">Enables thumbnail generation</flag>
- </use>
<maintainer type="project">
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <use>
+ <flag name="activities">Track which folders are frequently accessed on a Plasma desktop</flag>
+ <flag name="thumbnail">Enables thumbnail generation</flag>
+ </use>
</pkgmetadata>