summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-07 02:31:29 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-13 03:43:01 +1100
commitaf1968b4aaf6d6d0140f334c5814dee109e3e762 (patch)
tree097db3c940167eb06f6eab9114c93f0923296511 /kde-apps/dolphin
parentdev-lang/ekopath: Add slotted variants of the old versions (diff)
downloadgentoo-af1968b4aaf6d6d0140f334c5814dee109e3e762.tar.gz
gentoo-af1968b4aaf6d6d0140f334c5814dee109e3e762.tar.bz2
gentoo-af1968b4aaf6d6d0140f334c5814dee109e3e762.zip
kde-apps: Move kdecore-meta-15.12.2 and deps from kde overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-15.12.2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 2b1c4bc1a3df..ca61fd5e77b4 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-15.08.3.tar.xz 656904 SHA256 f5eda2eb0cf3900787013ac7425e89f2f9274f19a2a0a520443c8f34a13f0aa1 SHA512 13ca89ab32a8eb5fb2ee578c93462b49512b9fed45a2b2919b1a9c384c14fb86c55d693f452cbbbddb9286fff78ae6bfe63584b0f7fb0990a0ce3a535a48f0de WHIRLPOOL 57ef78e5648d7827a7064debc7dad45ba95021265a134de75fa26ccedebae2e7b39415616c79b43580dc165e5f541cee0951d2e198ec916a6d05a219dc3b6ce1
+DIST dolphin-15.12.2.tar.xz 658360 SHA256 6387ea81bec8f3a0c35fe9e319450bcb234127516e77198fbbbc4eb062c60231 SHA512 5ac27cd2d7f311c4e158c2448bbbf07e22af0dcc14ce6f21f42c8f5e50633d9ec7293dcde49a89d7627d4bd348517aab19cb0877d433f597f91d8d2c063ef0f2 WHIRLPOOL abfd2b4c9124b5b9721b91aa7eddbce95a9b5925a1b7685c11a36fb7fa4b0a24589b1f33fa608e889c20529094a9f7bfcaa235749a3ed64ab5d72fd223c646c8
DIST kde-baseapps-4.14.3.tar.xz 2548152 SHA256 125baf42a7ab8c255b5829d12837f54c1791498f79593a9b09a9e55344ade6db SHA512 d422c1ee5cd2e1dc15b5baa2199bb85441196bc3048b9bfa443f898c3a1cfbc7f66087edf016fb594b9e48340517beef54b4429b4fde664374e75486c7cb0f9e WHIRLPOOL b22a98d140bb66ea47aeb5607e606c7a531c82787e27204f5eabb7d29d763b2bfe1456d85242d3e05e7ab4d2366fc622ef1cc624dd1954e276fb36c49840998a
diff --git a/kde-apps/dolphin/dolphin-15.12.2.ebuild b/kde-apps/dolphin/dolphin-15.12.2.ebuild
new file mode 100644
index 000000000000..e1b8a6cbd702
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-15.12.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ || ( $(add_kdeapps_dep ffmpegthumbs) media-video/ffmpegthumbnailer )
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_KF5Baloo=$(usex semantic-desktop)
+ -DWITH_KF5BalooWidgets=$(usex semantic-desktop)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ echo
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ echo
+ fi
+}