summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/kdebase-kioslaves
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/kdebase-kioslaves')
-rw-r--r--kde-apps/kdebase-kioslaves/Manifest1
-rw-r--r--kde-apps/kdebase-kioslaves/files/kdebase-kioslaves-CVE-2014-8600.patch29
-rw-r--r--kde-apps/kdebase-kioslaves/kdebase-kioslaves-4.14.3.ebuild62
-rw-r--r--kde-apps/kdebase-kioslaves/metadata.xml8
4 files changed, 100 insertions, 0 deletions
diff --git a/kde-apps/kdebase-kioslaves/Manifest b/kde-apps/kdebase-kioslaves/Manifest
new file mode 100644
index 000000000000..f52cca023dfa
--- /dev/null
+++ b/kde-apps/kdebase-kioslaves/Manifest
@@ -0,0 +1 @@
+DIST kde-runtime-4.14.3.tar.xz 7867308 SHA256 78a74e519b4e897ffcee14be98eebd7b672ad2bb6e71a4aa2fe77682b5bc8605 SHA512 63b13f947915bb2eca5b85886610d1af480956b9e95a1ae77ce7c10b11576883a71bebf519335323a1f6c5dfcebe2ee0561b727cea6243756d412d9323feb244 WHIRLPOOL 4d021d826eb2ba553bb6fa320f71ed3d1f1614aef29f2d9e26285eabb9c015e6577e85ee6b0874cd1f8b89ef33cfa3dde5a6002e2178a11ede38cb8bf471a5a2
diff --git a/kde-apps/kdebase-kioslaves/files/kdebase-kioslaves-CVE-2014-8600.patch b/kde-apps/kdebase-kioslaves/files/kdebase-kioslaves-CVE-2014-8600.patch
new file mode 100644
index 000000000000..dcb20f8cb1f7
--- /dev/null
+++ b/kde-apps/kdebase-kioslaves/files/kdebase-kioslaves-CVE-2014-8600.patch
@@ -0,0 +1,29 @@
+From: Martin Sandsmark <martin.sandsmark@kde.org>
+Date: Thu, 13 Nov 2014 12:29:01 +0000
+Subject: Sanitize path
+X-Git-Url: http://quickgit.kde.org/?p=kde-runtime.git&a=commitdiff&h=d68703900edc8416fbcd2550cd336cbbb76decb9
+---
+Sanitize path
+---
+
+
+--- a/kioslave/bookmarks/kio_bookmarks.cpp
++++ b/kioslave/bookmarks/kio_bookmarks.cpp
+@@ -22,6 +22,7 @@
+ #include <stdlib.h>
+
+ #include <qregexp.h>
++#include <qtextdocument.h>
+
+ #include <kapplication.h>
+ #include <kcmdlineargs.h>
+@@ -197,7 +198,7 @@
+ echoImage(regexp.cap(1), regexp.cap(2), url.queryItem("size"));
+ } else {
+ echoHead();
+- echo("<p class=\"message\">" + i18n("Wrong request: %1",path) + "</p>");
++ echo("<p class=\"message\">" + i18n("Bad request: %1", Qt::escape(Qt::escape(url.prettyUrl()))) + "</p>");
+ }
+ finished();
+ }
+
diff --git a/kde-apps/kdebase-kioslaves/kdebase-kioslaves-4.14.3.ebuild b/kde-apps/kdebase-kioslaves/kdebase-kioslaves-4.14.3.ebuild
new file mode 100644
index 000000000000..c2e1d0ca9e5e
--- /dev/null
+++ b/kde-apps/kdebase-kioslaves/kdebase-kioslaves-4.14.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+KMMODULE="kioslave"
+inherit kde4-meta
+
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+DESCRIPTION="kioslave: the kde VFS framework - kioslave plugins present a filesystem-like view of arbitrary data"
+IUSE="+bzip2 exif debug lzma minimal openexr samba +sftp"
+
+# tests hang, last checked for 4.2.96
+RESTRICT="test"
+
+DEPEND="
+ virtual/jpeg:0
+ !aqua? ( x11-libs/libXcursor )
+ bzip2? ( app-arch/bzip2 )
+ exif? ( media-gfx/exiv2:= )
+ openexr? ( media-libs/openexr:= )
+ samba? ( || ( <net-fs/samba-4.0.0_alpha1[smbclient] >=net-fs/samba-4.0.0_alpha1[client] ) )
+ sftp? ( >=net-libs/libssh-0.4.0:=[sftp] )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdelibs 'bzip2?,lzma?')
+ $(add_kdeapps_dep kdialog)
+ virtual/ssh
+ !aqua? ( !kernel_SunOS? ( virtual/eject ) )
+"
+
+KMEXTRA="
+ kioexec
+ kdeeject
+"
+
+PATCHES=( "${FILESDIR}/${PN}-CVE-2014-8600.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SLP=OFF
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with exif Exiv2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ $(cmake-utils_use_with openexr OpenEXR)
+ $(cmake-utils_use_with samba)
+ $(cmake-utils_use_with sftp LibSSH)
+ )
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ if use minimal; then
+ rm "${D}"/usr/lib64/libmolletnetwork.so "${D}"/usr/share/config.kcfg/jpegcreatorsettings.kcfg
+ rmdir "${D}"/usr/share/config.kcfg/
+ fi
+}
diff --git a/kde-apps/kdebase-kioslaves/metadata.xml b/kde-apps/kdebase-kioslaves/metadata.xml
new file mode 100644
index 000000000000..a3be7e3f2b0c
--- /dev/null
+++ b/kde-apps/kdebase-kioslaves/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="sftp">Enable SFTP protocol support using <pkg>net-libs/libssh</pkg></flag>
+ </use>
+</pkgmetadata>