summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:13:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:46:08 +0200
commit2de492f66f593f97c84056a21259aaa5653681dd (patch)
treefe20d10d8a88b87b3b6ef55c8ac06f5b3621c0f0 /kde-apps/kdenetwork-meta
parentkde5.eclass: Disable kdoctools_install(po) if KDE_HANDBOOK=forceoptional (diff)
downloadgentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.gz
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.bz2
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.zip
kde-apps: Add KDE Applications 17.04.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kdenetwork-meta')
-rw-r--r--kde-apps/kdenetwork-meta/kdenetwork-meta-17.04.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-apps/kdenetwork-meta/kdenetwork-meta-17.04.1.ebuild b/kde-apps/kdenetwork-meta/kdenetwork-meta-17.04.1.ebuild
new file mode 100644
index 000000000000..4468332895a9
--- /dev/null
+++ b/kde-apps/kdenetwork-meta/kdenetwork-meta-17.04.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="kdenetwork - merge this to pull in all kdenetwork-derived packages"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls ppp"
+
+[[ ${KDE_BUILD_TYPE} = live ]] && L10N_MINIMAL=${KDE_APPS_MINIMAL}
+
+# FIXME: Add back whenever it gets ported
+# $(add_kdeapps_dep kopete)
+RDEPEND="
+ $(add_kdeapps_dep kdenetwork-filesharing)
+ $(add_kdeapps_dep kget)
+ $(add_kdeapps_dep krdc)
+ $(add_kdeapps_dep krfb)
+ $(add_kdeapps_dep plasma-telepathy-meta)
+ $(add_kdeapps_dep zeroconf-ioslave)
+ nls? ( $(add_kdeapps_dep kde4-l10n '' ${L10N_MINIMAL}) )
+ ppp? ( $(add_kdeapps_dep kppp) )
+"