summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 14:52:09 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-03 18:08:35 +0200
commit167c45876320bbea3bcbd9d749bcd438b6832c25 (patch)
tree3cbab5dbb9506cd91a5a883ff5b800266d5bb0c7 /kde-apps/kdepim-l10n
parentkde-apps/kde-l10n: Migrate to L10N (diff)
downloadgentoo-167c45876320bbea3bcbd9d749bcd438b6832c25.tar.gz
gentoo-167c45876320bbea3bcbd9d749bcd438b6832c25.tar.bz2
gentoo-167c45876320bbea3bcbd9d749bcd438b6832c25.zip
kde-apps/kdepim-l10n: Migrate to L10N
Diffstat (limited to 'kde-apps/kdepim-l10n')
-rw-r--r--kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild14
-rw-r--r--kde-apps/kdepim-l10n/kdepim-l10n-4.14.3-r1.ebuild16
-rw-r--r--kde-apps/kdepim-l10n/kdepim-l10n-4.4.11.1-r2.ebuild14
3 files changed, 19 insertions, 25 deletions
diff --git a/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild b/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
index 57055dcdeaac..e8c8248e1182 100644
--- a/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
+++ b/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
@@ -35,8 +35,8 @@ URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI=""
for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
+ IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
done
S="${WORKDIR}"
@@ -44,12 +44,10 @@ S="${WORKDIR}"
src_unpack() {
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
@@ -60,9 +58,9 @@ src_prepare() {
default
local LNG DIR
- # add all linguas to cmake
+ # add all l10n to cmake
if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
+ for LNG in ${MY_LANGS}; do
DIR="kde-l10n-${LNG}-${PV}"
SDIR="${S}/${DIR}/5/${LNG}"
if [[ -d "${DIR}" ]] ; then
diff --git a/kde-apps/kdepim-l10n/kdepim-l10n-4.14.3-r1.ebuild b/kde-apps/kdepim-l10n/kdepim-l10n-4.14.3-r1.ebuild
index 66fbf7209700..523c2b8f3621 100644
--- a/kde-apps/kdepim-l10n/kdepim-l10n-4.14.3-r1.ebuild
+++ b/kde-apps/kdepim-l10n/kdepim-l10n-4.14.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,8 +31,8 @@ URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI=""
for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
+ IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
done
S="${WORKDIR}"
@@ -40,12 +40,10 @@ S="${WORKDIR}"
src_unpack() {
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
@@ -55,9 +53,9 @@ src_unpack() {
src_prepare() {
local LNG DIR
- # add all linguas to cmake
+ # add all l10n to cmake
if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
+ for LNG in ${MY_LANGS}; do
DIR="kde-l10n-${LNG}-${PV}"
if [[ -d "${DIR}" ]] ; then
echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
diff --git a/kde-apps/kdepim-l10n/kdepim-l10n-4.4.11.1-r2.ebuild b/kde-apps/kdepim-l10n/kdepim-l10n-4.4.11.1-r2.ebuild
index 3f02b70e5745..56d98aa6cc31 100644
--- a/kde-apps/kdepim-l10n/kdepim-l10n-4.4.11.1-r2.ebuild
+++ b/kde-apps/kdepim-l10n/kdepim-l10n-4.4.11.1-r2.ebuild
@@ -32,8 +32,8 @@ URI_BASE="mirror://kde/Attic/4.4.5/src/kde-l10n"
SRC_URI=""
for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/kde-l10n-${MY_LANG}-4.4.5.tar.bz2 )"
+ IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE}/kde-l10n-${MY_LANG}-4.4.5.tar.bz2 )"
done
S="${WORKDIR}"
@@ -42,12 +42,10 @@ src_unpack() {
local LNG DIR
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
@@ -55,9 +53,9 @@ src_unpack() {
[[ -n ${A} ]] && unpack ${A}
cd "${S}"
- # for all linguas do:
+ # for all l10n do:
if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
+ for LNG in ${MY_LANGS}; do
einfo "Processing ${LNG} localization"
DIR="kde-l10n-${LNG}-4.4.5"