summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-19 21:00:05 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-19 21:08:28 +0100
commit5a888b5e522df982902580c5cbb9c5c0075ee3cb (patch)
treeb9e20014b4936456e2ac3e514595ff3d71063911 /kde-apps/kdepim-runtime
parentapp-backup/backintime-1.1.12-r0: stable on amd64 (diff)
downloadgentoo-5a888b5e522df982902580c5cbb9c5c0075ee3cb.tar.gz
gentoo-5a888b5e522df982902580c5cbb9c5c0075ee3cb.tar.bz2
gentoo-5a888b5e522df982902580c5cbb9c5c0075ee3cb.zip
kde-apps/kdepim-runtime: Fix ical data loss
Revision bump adds upstream patch reported on release mailing list. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.0-ical-data-loss.patch33
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-16.12.0-r1.ebuild87
2 files changed, 120 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.0-ical-data-loss.patch b/kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.0-ical-data-loss.patch
new file mode 100644
index 000000000000..182b8f29bd63
--- /dev/null
+++ b/kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.0-ical-data-loss.patch
@@ -0,0 +1,33 @@
+commit 8ae09b6f4afa8ceb2770da67b6dc79c78b86af47
+Author: David Faure <faure@kde.org>
+Date: Mon Dec 19 13:29:30 2016 +0100
+
+ Fix DATA LOSS bug in ical resource which failed to create std.ics if it didn't exist.
+
+ The default setup sets the Path to be a local path, not a URL.
+ => Use QUrl::fromUserInput so that it can deal with both cases, paths and URLs.
+
+ CCMAIL: smartins@kde.org, release-team@kde.org
+
+diff --git a/resources/shared/singlefileresource/singlefileresource.h b/resources/shared/singlefileresource/singlefileresource.h
+index f3c19aaf5..3f4149903 100644
+--- a/resources/shared/singlefileresource/singlefileresource.h
++++ b/resources/shared/singlefileresource/singlefileresource.h
+@@ -55,7 +55,7 @@ public:
+ , mSettings(new Settings(config()))
+ {
+ // The resource needs network when the path refers to a non local file.
+- setNeedsNetwork(!QUrl(mSettings->path()).isLocalFile());
++ setNeedsNetwork(!QUrl::fromUserInput(mSettings->path()).isLocalFile());
+ }
+ ~SingleFileResource()
+ {
+@@ -82,7 +82,7 @@ public:
+ return;
+ }
+
+- mCurrentUrl = QUrl(mSettings->path()); // path already has scheme
++ mCurrentUrl = QUrl::fromUserInput(mSettings->path()); // the string contains the scheme if remote, doesn't if local path
+ if (mCurrentHash.isEmpty())
+ {
+ // First call to readFile() lets see if there is a hash stored in a
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-16.12.0-r1.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-16.12.0-r1.ebuild
new file mode 100644
index 000000000000..797a0755008a
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-16.12.0-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="google ssl"
+
+# TODO kolab, Qt5TextToSpeech
+
+CDEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libical:=
+ google? ( >=net-libs/libkgapi-5.1.0:5 )
+ ssl? ( dev-libs/cyrus-sasl )
+"
+DEPEND="${CDEPEND}
+ $(add_frameworks_dep kross)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libxslt
+ x11-misc/shared-mime-info
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-kioslaves
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-ical-data-loss.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package google KF5GAPI)
+ $(cmake-utils_use_find_package ssl Sasl2)
+ )
+
+ kde5_src_configure
+}