summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/kig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/kig')
-rw-r--r--kde-apps/kig/Manifest1
-rw-r--r--kde-apps/kig/files/kig-4.12.0-boostpython.patch17
-rw-r--r--kde-apps/kig/kig-4.14.3.ebuild43
-rw-r--r--kde-apps/kig/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/kde-apps/kig/Manifest b/kde-apps/kig/Manifest
new file mode 100644
index 000000000000..c750e014ee35
--- /dev/null
+++ b/kde-apps/kig/Manifest
@@ -0,0 +1 @@
+DIST kig-4.14.3.tar.xz 1506492 SHA256 2e71d86b14b4d09722b54e7b239c238558d35227465c0e5c62e9e6eb34cce3ce SHA512 218fce708a3fa5478bb50bd5a239479655a8168f8df069b819578701165f9ad9202015600eb2c44ff9580355459ce423ef83814d771079adebb940fa137a5813 WHIRLPOOL 6992a150ab19a373dd4fe791babd10a1cc65b61d5c01827c12b6b51183d43a0ba8f46105a6f2c710217dea8f3e3d3e9351ea3bdef0ca3a9fe6bad171c00fb479
diff --git a/kde-apps/kig/files/kig-4.12.0-boostpython.patch b/kde-apps/kig/files/kig-4.12.0-boostpython.patch
new file mode 100644
index 000000000000..7a4b878c6bc3
--- /dev/null
+++ b/kde-apps/kig/files/kig-4.12.0-boostpython.patch
@@ -0,0 +1,17 @@
+diff --git a/cmake/modules/FindBoostPython.cmake b/cmake/modules/FindBoostPython.cmake
+index 2ccc161..02d9bf6 100644
+--- a/cmake/modules/FindBoostPython.cmake
++++ b/cmake/modules/FindBoostPython.cmake
+@@ -74,10 +74,10 @@ if(HAVE_BOOST_SHARED_PTR_HPP AND Boost_PYTHON_FOUND)
+ # Second try: try pkg-config way
+ find_package(PkgConfig)
+ if(PKG_CONFIG_FOUND)
+- set(PYTHON_VERSIONS "python;python2.7;python2.6;python2.5;python2.4;python2.3;python2.2")
++ execute_process(COMMAND python -c "import sys; sys.stdout.write('.'.join(str(x) for x in sys.version_info[:2]))" OUTPUT_VARIABLE PYTHON_VERSIONS)
+ foreach(_pyver ${PYTHON_VERSIONS})
+ if(NOT BoostPython_INCLUDES OR NOT BoostPython_LIBS)
+- pkg_check_modules(${_pyver} QUIET ${_pyver})
++ pkg_check_modules(_python python-${_pyver})
+ if(${_pyver}_FOUND)
+ cmake_push_check_state()
+ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${${_pyver}_INCLUDE_DIRS}) \ No newline at end of file
diff --git a/kde-apps/kig/kig-4.14.3.ebuild b/kde-apps/kig/kig-4.14.3.ebuild
new file mode 100644
index 000000000000..e060bbbe1ed9
--- /dev/null
+++ b/kde-apps/kig/kig-4.14.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="http://www.kde.org/applications/education/kig http://edu.kde.org/kig"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kig/metadata.xml b/kde-apps/kig/metadata.xml
new file mode 100644
index 000000000000..76914c709991
--- /dev/null
+++ b/kde-apps/kig/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="scripting">Support Python scripting</flag>
+ </use>
+ <herd>kde</herd>
+</pkgmetadata>