summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/kio-extras
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kio-extras')
-rw-r--r--kde-apps/kio-extras/Manifest1
-rw-r--r--kde-apps/kio-extras/files/kio-extras-19.08.3-libssh-0.9.2.patch88
-rw-r--r--kde-apps/kio-extras/kio-extras-19.08.3.ebuild83
3 files changed, 172 insertions, 0 deletions
diff --git a/kde-apps/kio-extras/Manifest b/kde-apps/kio-extras/Manifest
index eeaaf7becca9..f16b31e2d0b7 100644
--- a/kde-apps/kio-extras/Manifest
+++ b/kde-apps/kio-extras/Manifest
@@ -1 +1,2 @@
+DIST kio-extras-19.08.3.tar.xz 577520 BLAKE2B 2ceb208b1860e83b818935d6890194d27ad05c2d058d1d03167969539c41a99172b08c7196ade159e332e562c5573614e79f920415dccf16e4e1918471d92c22 SHA512 e2e5c6e3a8487c7251b77283c63eae75ea071f9d9f5f4544690083ab7f834abf6b10c715cad4fb49fbbfa34d2fbf9de358a4c606b299b2f4bf44444a57cadba6
DIST kio-extras-19.12.3.tar.xz 581020 BLAKE2B b4f9ca0812d535222c1a156ef2ce056df95dfab0786b108418fc98da860617c272ffaab044d0faf8559dee04d8bbc799da6eb004bea170c41a1b3bd30e91a40f SHA512 289d4336e563ee38be20f40c146172111ebeb3893edd15c76ad42435b8b1b0967864d8764519cd5c0aaa2580c56b76283076a3598917876b5e22acdf75ba9da7
diff --git a/kde-apps/kio-extras/files/kio-extras-19.08.3-libssh-0.9.2.patch b/kde-apps/kio-extras/files/kio-extras-19.08.3-libssh-0.9.2.patch
new file mode 100644
index 000000000000..b133140ac269
--- /dev/null
+++ b/kde-apps/kio-extras/files/kio-extras-19.08.3-libssh-0.9.2.patch
@@ -0,0 +1,88 @@
+From 24506c2af8d1904a99538543804306c6c2b81ca2 Mon Sep 17 00:00:00 2001
+From: Harald Sitter <sitter@kde.org>
+Date: Wed, 6 Nov 2019 13:57:20 +0100
+Subject: make the libssh finder ensure the new ssh target is set
+
+Summary:
+starting with 0.9.2 the libssh cmake config defines a new ssh imported
+target, use this as the new gold standard and ensure older versions
+are compatible
+
+broken ubuntu: no cmake config -> manual finder -> target injected
+0.9.0 and earlier: cmake config -> target injected
+0.9.2: cmake config -> target already defined; noop
+
+(0.9.1 is broken as it neither matches the old nor the new expectation)
+
+Test Plan:
+no cmake config -> target injected
+older cmake config -> target injected
+newer cmake config (with merge request) -> noop
+
+Subscribers: kde-frameworks-devel, kfm-devel
+
+Tags: #dolphin, #frameworks
+
+Differential Revision: https://phabricator.kde.org/D25170
+---
+ cmake/Findlibssh.cmake | 18 ++++++++++++++++++
+ sftp/CMakeLists.txt | 2 +-
+ 2 files changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/cmake/Findlibssh.cmake b/cmake/Findlibssh.cmake
+index bf6d797..f37846f 100644
+--- a/cmake/Findlibssh.cmake
++++ b/cmake/Findlibssh.cmake
+@@ -32,6 +32,19 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+
++# Define an imported target to have compatibility with newer libssh and so
++# we have a single target to use regardless of the code path taken in the
++# finder and the actual libssh version defining the target.
++macro(libssh_ensure_imported_target)
++ if(NOT TARGET ssh)
++ add_library(ssh SHARED IMPORTED)
++ set_target_properties(ssh PROPERTIES
++ IMPORTED_LOCATION "${LIBSSH_LIBRARIES}"
++ INTERFACE_INCLUDE_DIRECTORIES "${LIBSSH_INCLUDE_DIR}"
++ )
++ endif()
++endmacro()
++
+ # We prefer the config, but on Ubuntu 18.04 LTS (and to some extent later
+ # versions it seems) they've not packaged the config properly. So, go for the
+ # config by default and fall back to manual lookup iff the config was not found.
+@@ -39,6 +52,9 @@
+ # https://bugs.launchpad.net/ubuntu/+source/libssh/+bug/1800135
+ find_package(libssh ${libssh_FIND_VERSION} NO_MODULE QUIET)
+ if(libssh_FOUND)
++ # Certain versions with config may not have the target, so make sure it's
++ # defined.
++ libssh_ensure_imported_target()
+ return()
+ endif()
+
+@@ -109,5 +125,7 @@ find_package_handle_standard_args(libssh
+ VERSION_VAR
+ LIBSSH_VERSION)
+
++libssh_ensure_imported_target()
++
+ # show the LIBSSH_INCLUDE_DIRS and LIBSSH_LIBRARIES variables only in the advanced view
+ mark_as_advanced(LIBSSH_INCLUDE_DIR LIBSSH_LIBRARIES)
+diff --git a/sftp/CMakeLists.txt b/sftp/CMakeLists.txt
+index cd09cd3..5d1eccb 100644
+--- a/sftp/CMakeLists.txt
++++ b/sftp/CMakeLists.txt
+@@ -22,7 +22,7 @@ target_link_libraries(kio_sftp
+ KF5::WidgetsAddons # KMessageBox
+ KF5::I18n
+ Qt5::Network
+- ${LIBSSH_LIBRARIES})
++ ssh)
+ set_target_properties(kio_sftp PROPERTIES OUTPUT_NAME "sftp")
+
+ install(TARGETS kio_sftp DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf5/kio)
+--
+cgit v1.1
diff --git a/kde-apps/kio-extras/kio-extras-19.08.3.ebuild b/kde-apps/kio-extras/kio-extras-19.08.3.ebuild
new file mode 100644
index 000000000000..949b89338838
--- /dev/null
+++ b/kde-apps/kio-extras/kio-extras-19.08.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="optional"
+KFMIN=5.60.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KIO plugins present a filesystem-like view of arbitrary data"
+HOMEPAGE="https://cgit.kde.org/kio-extras.git"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~arm arm64"
+IUSE="activities +man mtp openexr phonon samba +sftp taglib"
+
+BDEPEND="
+ man? ( dev-util/gperf )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5[bzip2,lzma]
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ activities? (
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ )
+ man? ( >=kde-frameworks/khtml-${KFMIN}:5 )
+ mtp? ( >=media-libs/libmtp-1.1.16:= )
+ openexr? ( media-libs/openexr:= )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ samba? ( net-fs/samba[client] )
+ sftp? ( net-libs/libssh:=[sftp] )
+ taglib? ( >=media-libs/taglib-1.11.1 )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kded-${KFMIN}:5
+"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-libssh-0.9.2.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package activities KF5Activities)
+ $(cmake_use_find_package man Gperf)
+ $(cmake_use_find_package mtp Mtp)
+ $(cmake_use_find_package openexr OpenEXR)
+ $(cmake_use_find_package phonon Phonon4Qt5)
+ $(cmake_use_find_package samba Samba)
+ $(cmake_use_find_package sftp libssh)
+ $(cmake_use_find_package taglib Taglib)
+ )
+
+ ecm_src_configure
+}